Showing results 1 to 8 of 8

Thread: Time Control is not executing any task

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    24.08.2020
    Posts
    5

    Default Time Control is not executing any task

    Hi community
    I am having a problem with executing tasks with the Time Control of Zenon. A lot of testing and forum search has been done by me at the last days without fixing the problem.

    We are running two Zenon server in redundancy and a client.
    All using Zenon 8.10 SP0 Build 67223 64-bit, Supervisor edition on server and client.
    The client should execute a VBA script for copying a file to a share once a day.

    1. I created the VBA function on the client project with additional logging in case it has been called. So I know it worked
    2. A function has been created under the client project to call the VBA macro.
    3. A TimeControl entry has been created within the client project to call the function
    4. Zenon HMI on Client has been restarted -> no VBA called at the given time even after some days.
    5. Server HMI has been restarted in case of I-don't-know.

    Here is the screenshot of the Time Control settings. In the meantime I added different entries to check if a simple bit toggle is executed. But none of these entries is working.


    What did I wrong?
    Is there a known issue with the used Zenon version?

    Thanks in advanced
    Attached Thumbnails Attached Thumbnails Zenon_TimeControl_Settings.PNG  

Similar Threads

  1. Script called by Reaction Matrix not executing properly
    By OzKa in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 0
    Last Post: 29th April 2021, 10:39
  2. Time control function - interval
    By geleto021 in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 4
    Last Post: 23rd June 2020, 14:39
  3. Replies: 1
    Last Post: 29th September 2017, 10:52
  4. Time Control (Zeitsteuerung) ist not working
    By BrunoBruno in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 2
    Last Post: 22nd July 2016, 11:57
  5. Executing a function based on computer name
    By craigdouglas in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 1
    Last Post: 20th November 2008, 20:17

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •