Showing results 1 to 2 of 2

Thread: Zenon editor 8.2 install fails, due to SQL Server Rules Check code (-1)

  1. #1
    Join Date

    Default Zenon editor 8.2 install fails, due to SQL Server Rules Check code (-1)

    Brand new to Zenon software. The Zenon 8.20 software refuses to install. Its hanging on SQL Server install rules check.
    Iíve tried Win7 (before I found out Win7 can't run the editor!), and also a brand new Win10 Enterprise vm box with no other softwares installed. I get same error with each. I googled the error and canít find any info, nor could I initially find the log file from SQL Server install. I clicked the link and I get nothing, see image attached.  So I went searching for a log file and found one. I found where its doing the Rules check and fails, but it still doesnít tell me what the error actually means. Here is an excerpt from the logfile.

    2-27-2021[01:46:37 PM]: Running event 'CheckSQLServerRules'
    2-27-2021[01:46:37 PM]: Engine: request for proxy handler, 0, 0
    2-27-2021[01:46:37 PM]: (CLR Action): Attempting to load through CLR 4 APIs...
    2-27-2021[01:46:37 PM]: (CLR Action): Getting meta host...
    2-27-2021[01:46:37 PM]: (CLR Action): Enumerating available runtimes...
    2-27-2021[01:46:37 PM]: (CLR Action): Highest available runtime: v4.0.30319
    2-27-2021[01:46:37 PM]: (CLR Action): Trying to use highest runtime...
    2-27-2021[01:46:37 PM]: (CLR Action): Using highest version runtime...
    2-27-2021[01:46:37 PM]: (CLR Action): CDEXECUTE: CheckSQLServerRules
    2-27-2021[01:46:37 PM]: (CLR Action): TryGetSuiteProperty: CDSUITE_SQLCHECKPATH
    2-27-2021[01:46:37 PM]: (CLR Action): SuiteProperty: CDSUITE_SQLCHECKPATH - Value: E:\Setup\SetupPrerequisites\Microsoft SQL Server Express (x64)\SETUP.exe
    2-27-2021[01:46:37 PM]: (CLR Action): TryGetSuiteProperty: CDSUITE_SQLCHECKARGS
    2-27-2021[01:46:37 PM]: (CLR Action): SuiteProperty: CDSUITE_SQLCHECKARGS - Value: /ACTION=RunRules /RULES=SCCCheckRules /Q /HIDECONSOLE
    2-27-2021[01:46:37 PM]: (CLR Action): TryGetSuiteProperty: CDSUITE_SQLCHECKLOGDIR
    2-27-2021[01:46:37 PM]: (CLR Action): SuiteProperty: CDSUITE_SQLCHECKLOGDIR - Value: C:\Program Files\Microsoft SQL Server\140\Setup Bootstrap\Log
    2-27-2021[01:46:37 PM]: (CLR Action): TryGetSuiteProperty: CDSUITE_SQLCHECKLOGNAME
    2-27-2021[01:46:37 PM]: (CLR Action): SuiteProperty: CDSUITE_SQLCHECKLOGNAME - Value: SystemConfigurationCheck_Report.htm
    2-27-2021[01:46:37 PM]: (CLR Action): CDEXECUTE: Process exites with code -1
    2-27-2021[01:46:37 PM]: Engine: property 'CDPROP_SQLCHECKERROR' value now '-1'
    2-27-2021[01:46:37 PM]: Action returned value 0x00000643
    2-27-2021[01:46:37 PM]: Action 'CheckSQLServerRules' returned status 0x80070643
    2-27-2021[01:46:37 PM]: Engine: property 'ISInstallStatus' value now 'IDS_SUITE_INTERRUPTED'

    I tried mounting the ISO file, and Iíve tried copying the ISO file contents to a folder on my c:\ drive, same result in both cases.  I donít have SQL Server installed already, see screenshot.  I am running the setup file as Admin.  Iíve tried to manually install SQL Server from the \AdditionalSoftware\Microsoft SQL Server 2017 Express Edition folder (as admin also), running the batch file as Admin and it still fails, saying my PC cannot run this software?
    I cannot do anything with the software right now, which is really frustrating. I need some assistance please. Iíve checked out the forum, and found nothing helpful.  Do I need to download SQL Server Express 2017 and install separately? Or actually burn the ISO file to a DVD? I tried disabling Windows Defender firewall and no effect. No antivirus installed currently either. 
    Here is the fresh vm that Iím using, version details:
    Edition  Windows 10 Enterprise
    Version 20H2
    Installed on         ‎11/‎22/‎2020
    OS build               19042.630
    Experience         Windows Feature Experience Pack 120.2212.31.0

    Attached Thumbnails Attached Thumbnails can't install sql server express manually.jpg   Win10 installed programs.jpg   zenon error can't install.jpg  

  2. #2
    Join Date

    Default Re: Zenon editor 8.2 install fails, due to SQL Server Rules Check code (-1)

    Problem is resolved. The ISO file was corrupted during download which was causing the installation errors. Had to download a new copy of the ISO. All works now. Thanks to COPA DATA tech support for their help!

Similar Threads

  1. Connecting OPC DA server to zenon Editor
    By razorqhex in forum Engineering Studio & Service Engine
    Replies: 1
    Last Post: 8th June 2020, 14:12
  2. Replies: 2
    Last Post: 25th August 2017, 11:10
  3. SQL Server installation aborts - MSXML 6.0 Parser installation fails
    By ralff in forum Engineering Studio & Service Engine
    Replies: 0
    Last Post: 18th August 2010, 14:52
  4. Replies: 0
    Last Post: 11th March 2010, 15:59
  5. Version 6.21; SQL Server installation fails
    By stefan_m in forum Engineering Studio & Service Engine
    Replies: 0
    Last Post: 12th September 2007, 07:40

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts