Showing results 1 to 3 of 3

Thread: Register OCX libraries from (Win7 - Zenon 6.51) to (Win 10 - Zenon 7.6)

  1. #1
    Join Date
    27.07.2018
    Posts
    1

    Default Register OCX libraries from (Win7 - Zenon 6.51) to (Win 10 - Zenon 7.6)

    Hi all,

    I have an application developed in Zenon 6.51 which I need to update it to Zenon 7.6

    There is no issues with the Zenon update except a VBA issue with the progressBar but once I sort it out other ActiveX might also have similar problems

    After registering mscomctl.ocx (Microsoft Windows Common Controls 6.0 SP4 or SP6) in the new Zenon 7.6 installation it appear in the references (see image attached) but it does not appear in the additional controls tab (available controls).

    If it does not appear in available controls I am unable to add it to the toolbox and so to add it to the form or when importing the old project the object progressBar is not available and it does not gets copied.

    Is there any known incompatibilities? 

    What can be done to add the the control in the toolbox?

    Thanks
    Attached Thumbnails Attached Thumbnails Capture.JPG  

  2. #2
    Join Date
    10.12.2007
    Posts
    235

    Default AW: Register OCX libraries from (Win7 - Zenon 6.51) to (Win 10 - Zenon 7.6)

    Do you use zenon editor in 64bit mode? Mscomctl.ocx works only in 32bit mode.

  3. #3
    Join Date
    17.09.2020
    Posts
    2

    Default Re: Register OCX libraries from (Win7 - Zenon 6.51) to (Win 10 - Zenon 7.6)

    Hi Mst,

    I have tried with both, 32 and 64 bits versions. I must say that in the 32 bits version calendar and other controls appeared in the controls tab (available controls) but not the progressBar. If you do not have any other suggestions I will try it again with the 32 bits version.

    Thanks

Similar Threads

  1. Zenon Driver cannot register
    By shaun in forum zenon Supervisor
    Replies: 1
    Last Post: 4th March 2019, 08:42
  2. ARX Formatunterschiede in Win7 / WinXP ?
    By wrs402 in forum zenon Supervisor
    Replies: 4
    Last Post: 29th August 2012, 01:31
  3. Probleme mit WebClient und IE 9 / WIN7
    By kfn3000 in forum zenon Network
    Replies: 5
    Last Post: 23rd July 2012, 07:42
  4. How can I read this two type of Data register?
    By michael_k in forum Drivers
    Replies: 1
    Last Post: 24th November 2009, 16:23

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •