Showing results 1 to 6 of 6

Thread: WEB Server does not start

  1. #1
    Join Date
    08.02.2018
    Posts
    9

    Default WEB Server does not start

    Hello,

    I am using Zenon8.00.
    When project compiled for web I get warning like this : Illegal characters in path. 
    Runtime and Webserver installed on same computer.
    When I try to start WebServer it is not starting, simply nothing happens. 

    I updated global_vars.js file with project name and computer name, but still Web Server is not starting.

    I kindly ask your assistance to understand problem. 

    Thank you


    Attached Thumbnails Attached Thumbnails compile.PNG   global_vars.PNG   webserver.PNG  

  2. #2
    Join Date
    03.11.2015
    Posts
    54

    Default Re: WEB Server does not start

    Hello,

    may I ask what you like to deploy?
    In case of a HTML5 webengine you do not need a web server. In case you'd like to deploy a regular web client you do not need to compile for web.

    Does the directory of the project or the project itself contain any special character?

    BR,
    Joris

  3. #3
    Join Date
    08.02.2018
    Posts
    9

    Default Re: WEB Server does not start

    Hello Joris,

    Thanks for your answer.
    I typed in red my answers.

    Quote Originally Posted by joris.l View Post
    Hello,

    may I ask what you like to deploy? I would like use Web Server.

    In case of a HTML5 webengine you do not need a web server. In case you'd like to deploy a regular web client you do not need to compile for web. 

    Does the directory of the project or the project itself contain any special character? 
    Runtime Project directory "C:\Users\Etap\Desktop\ETI"
    Project Name "CENGIZ_GES"


    BR,
    Joris



  4. #4
    Join Date
    03.11.2015
    Posts
    54

    Default Re: WEB Server does not start

    If you simply like to use the web server without HMTL5 solution, you do not need to compile the project for web.
    Simply create the runtime files and start the runtime, configure the Web Server with the global_vars.js config and connect to the runtime over a web client.

  5. #5
    Join Date
    08.02.2018
    Posts
    9

    Default Re: WEB Server does not start

    Hello,

    I am using Demo Licence.

    I applied your instructions, but result is same.

    I checked with Diagnosis Viewer, screenshot in the attach.
    Isn't it possible to start WebServer with Demo licence?

    Regards,

    Attached Thumbnails Attached Thumbnails WebServerLicence.PNG  

  6. #6
    Join Date
    03.11.2015
    Posts
    54

    Default Re: WEB Server does not start

    It's possible to run the web server with a Demo license, unless the demo has a trial period set and has ended.
    You can verify this in the license manager.

    I would recommend to open the web server window and press "start". After starting, the web server will show "Running in Demo Mode" and show available clients, or not launching at all.

Similar Threads

  1. Zenon RT Services won't start on Standby Server
    By Pooyan_s95 in forum zenon Network
    Replies: 2
    Last Post: 20th May 2020, 12:53
  2. Web Server Pro Light - how to start, which browser I can use
    By yolovs in forum Webserver / Webclient Setup
    Replies: 3
    Last Post: 23rd October 2017, 12:48
  3. Web Server Runtime - Start and pictures
    By martin@bmw in forum Webserver/Webclient
    Replies: 1
    Last Post: 29th June 2009, 19:56
  4. Start Function From PCE
    By stephanepilon in forum VBA
    Replies: 1
    Last Post: 16th May 2008, 06:33
  5. Start a VBA Macro with PCE
    By mrk in forum VBA
    Replies: 1
    Last Post: 21st March 2008, 17:43

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •