Showing results 1 to 6 of 6

Thread: einchecken von Bildern funktioniert nicht mehr

  1. #1
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    181

    Default einchecken von Bildern funktioniert nicht mehr

    Hallo zusammen,

    letzten Freitag wollte Microsoft ein Update für den SQL Server 2012 durchführen. Während dieses durchgeführt wurde, war auf dem Rechner ein Mehrbenutzer-Projekt, das dort im Servermodus installiert ist, geöffnet und darin waren die Bilder ausgecheckt. Das war offensichtlich ungeschickt, denn nach erfolgreichem Update lassen sie sich jetzt nicht mehr einchecken. Ein solches Problem kannte ich bis jetzt nur von Rechnern, auf denen nicht direkt im Servermodus gearbeitet wurde. Hier stehe ich jetzt ratlos davor und frage mich: wie bekomme ich das Projekt wieder sauber? Falls mir da jemand einen Tipp hat: immer her damit!

    Viele Grüße

    Michael

    P.S.: die Fehlermeldung, die im DiagViewer zu jedem einzelnen ausgecheckten Bild eingetragen wird, lautet: SendToMUSRVCheckInBinary Server Error:-4 Text:Error CheckInBinary: 'C:\ProgramData\COPA-DATA\SQL2012\75852454-2a89-48d3-9882-7c231a698a5f\FILES\zenon\system\pictures\febd952e-3072-4122-9769-7a6ee1373697.ZP' UnLockRes failed '75852454-2a89-48d3-9882-7c231a698a5f'!
    zenOn Supervisor 7.60 + webserver pro


    Windows Server 2008 R2 / Windows 10 Enterprise


    ModbusTCP / LON / OPC / SQL / B&R / SNMP

  2. #2
    Join Date
    28.02.2013
    Posts
    200

    Default Re: einchecken von Bildern funktioniert nicht mehr

    Hallo Michael,

    sind die Datenbanken online?

    Schöne Grüße,
    Felix

  3. #3
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    181

    Default Re: einchecken von Bildern funktioniert nicht mehr

    Quote Originally Posted by felixst View Post
    Hallo Michael,

    sind die Datenbanken online?

    Schöne Grüße,
    Felix

    Hallo Felix,

    für mein etwas laienhaftes Verständnis von Datenbanken sieht es so aus, ja. Ich habe mit dem Server communication test tool versucht, eine Verbindung aufzubauen, und das meldet als Status "online" und zeigt mir auch die Variablen an. Allerdings kamen während der Verbindungsherstellung im DiagViewer jede Menge Meldungen, die alle so aussahen:

    GetBinaryStatusList Server Error:-2 Text:Error GetBinaryStatusList :'75852454-2a89-48d3-9882-7c231a698a5f_local' is Locked!

    Das "is locked" interpretiere ich jetzt mal als "ausgecheckt"? Was ja den Zustand bestätigen würde.
    zenOn Supervisor 7.60 + webserver pro


    Windows Server 2008 R2 / Windows 10 Enterprise


    ModbusTCP / LON / OPC / SQL / B&R / SNMP

  4. #4
    Join Date
    28.02.2013
    Posts
    200

    Default Re: einchecken von Bildern funktioniert nicht mehr

    Hallo Michael,

    dann könntest du versuchen die Client Verbindung zu trennen, die die Sperre hält.

    Details findest du dazu in der Hilfe: Handbuch > Verteiltes Engineering > Umgang mit einem Mehrplatzfähigen Projekt > Clientverbindung trennen

    Achtung: Dabei gehen die Änderungen vom Client verloren!

    Schöne Grüße,
    Felix

  5. #5
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    181

    Default Re: einchecken von Bildern funktioniert nicht mehr

    Quote Originally Posted by felixst View Post
    Hallo Michael,

    dann könntest du versuchen die Client Verbindung zu trennen, die die Sperre hält.

    Details findest du dazu in der Hilfe: Handbuch > Verteiltes Engineering > Umgang mit einem Mehrplatzfähigen Projekt > Clientverbindung trennen

    Achtung: Dabei gehen die Änderungen vom Client verloren!

    Schöne Grüße,
    Felix


    Das Problem war, dass niemand was ausgecheckt haben wollte... frei nach dem Motto: "Ich war's nicht!". Das macht dann das Auffinden der richtigen Verbindung etwas schwierig. Und weil es halt so aussah, als wäre das Phänomen zeitgleich mit dem Microsoft-SQL-Update aufgetreten, wurde das auch als erste Ursache vermutet. - Aber es hat schließlich doch geklappt und das Projekt ist wieder normal bearbeitbar. - Vielen Dank für die Tipps!
    zenOn Supervisor 7.60 + webserver pro


    Windows Server 2008 R2 / Windows 10 Enterprise


    ModbusTCP / LON / OPC / SQL / B&R / SNMP

  6. #6
    Join Date
    28.02.2013
    Posts
    200

    Default Re: einchecken von Bildern funktioniert nicht mehr

    Hallo Michael,

    danke für die Rückmeldung!

    Schöne Grüße aus Salzburg,
    Felix

Similar Threads

  1. Webclient funktioniert nach einiger Zeit nicht mehr
    By harry1008 in forum Webserver/Webclient
    Replies: 2
    Last Post: 5th June 2019, 10:08
  2. Replies: 9
    Last Post: 24th August 2018, 15:56
  3. VBA funktioniert nicht im WebClient
    By zero in forum Webserver / Webclient Setup
    Replies: 5
    Last Post: 6th August 2018, 14:36
  4. Verriegelung funktioniert nicht...
    By karnst in forum zenon Supervisor
    Replies: 3
    Last Post: 21st September 2011, 07:20
  5. Replies: 3
    Last Post: 17th October 2008, 12:43

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •