Showing results 1 to 9 of 9

Thread: Two versions of program in parallel

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    13.12.2019
    Posts
    2

    Default Two versions of program in parallel

    Can I use two versions of the program in parallel? I have several old projects, I'm worried about their compatibility with the new version of the system that I am going to purchase.


    Anyone saying that they will never need to take out a loan, I suggest thinking twice. I was certain I wouldn’t need one like ever; little did I know. A loan practically saved me from losing a roof over my head, and I am very thankful. Try these guys if you’re ever in trouble.
    Last edited by epenterh : 31st January 2020 at 20:09

  2. #2

    Default Re: Two versions of program in parallel

    Hello epenterh,

    It is possible to install and use multiple versions of the editor and/or the runtime on the same system, provided a license is available. An application called "startup tool", which is installed with the editor and with the runtime, should then be used to first register the appropriate version that is going to be used. This way you can keep different projects in the editor in their original version.

    The editor also provides compatibility options. When a project is converted to the latest version of the editor, an option in the editor still allows creating runtime files for a project, for an older version of the runtime.

    It is also possible to use a newer version of the runtime with runtime files compiled for an older version, without the need to convert the project in the editor.

    Best regards,
    Mark

  3. #3
    Join Date
    18.07.2017
    Posts
    12

    Default Re: Two versions of program in parallel

    Hi Mark

    Hope you are fine

    According to above statement, could you please tell me, how it's possible to load compiled RT files with lower version in to upper version of zenon RT application?
    For example : in Editor version 8.10 I compiled RT files for RT version 7.50, is it possible to load these files in zenon RT version 8.10?

    In fact, as my workarounds show, it is not possible to load lower version RT compiled files in current version of RT! and it returns below errors. 

    Thank you in advanced


  4. #4
    Join Date
    10.12.2007
    Posts
    260

    Default AW: Two versions of program in parallel

    Have a look at RT changeable data in the project settings. You have to create the useradministartion (and maybe other modules from the dialogue) new for version 7.50. Simply uncheck the checkboxes in the dialogue in the column 'don't create/transport RT files'

  5. #5
    Join Date
    18.07.2017
    Posts
    12

    Default Re: AW: Two versions of program in parallel

    Quote Originally Posted by mst View Post
    Have a look at RT changeable data in the project settings. You have to create the useradministartion (and maybe other modules from the dialogue) new for version 7.50. Simply uncheck the checkboxes in the dialogue in the column 'don't create/transport RT files'

    Hi mst

    Thank you for the hints, it seems that with unchecking RT changeable data i can now load any version of zenon RT files in zenon RT 8.10 application.
    Do you have any experience on networking upper version server with lower version client ? Does this kind of networking works properly?

    Thanks once again

  6. #6
    Join Date
    10.12.2007
    Posts
    260

    Default AW: Two versions of program in parallel

    You can have different versions on clients and server - but, you have to make sure that the runtimefiles are created for the lowest version that is installed on any machine.

    For example, let's say you have a 8.10 server, one 7.50 RT Client and another 7.20 RT Client, then the RT Files must be created for version 7.20 (or lower). If you would create RT Files for 7.50, the 7.20 Clients RT wouldn't "understand" the RT Files.

Similar Threads

  1. Installation of editor6.51 and 7.11 in parallel
    By peterhafner in forum zenon Service Engine Supervisor
    Replies: 2
    Last Post: 21st February 2014, 13:05
  2. What SNMP versions are supported in what versions?
    By stolyarov_as in forum zenon Service Engine Supervisor
    Replies: 2
    Last Post: 20th September 2013, 07:42
  3. Zenon OPC Server Versions and Compliances?
    By hoscillada in forum Drivers
    Replies: 15
    Last Post: 15th June 2013, 01:39
  4. parallel installation of two servicepacks
    By markclemens in forum Engineering Studio & Service Engine
    Replies: 1
    Last Post: 24th February 2009, 09:00
  5. available zenOn versions for CE versions and platforms
    By sebastiank in forum zenon Service Engine Operator
    Replies: 0
    Last Post: 20th September 2007, 08:09

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •