Showing results 1 to 3 of 3

Thread: Alarm raised time is incorrect

  1. #1
    Join Date
    05.02.2019
    Posts
    2

    Default Alarm raised time is incorrect

    Hi,
    I have developed a SCADA application in Zenon 7.6 supervisor. Used default alarm message list (AML) screen with all default settings.
    When i run the offline program it was working fine. But when the scada is running online connected to PLC, the alarm raised time is shown as some default constant time, whereas the alarm acknowledged time is shown correctly. Can anyone please help me with how to troubleshoot this issue and rectify it.

    Thanks..

  2. #2
    Join Date
    28.02.2013
    Posts
    189

    Default Re: Alarm raised time is incorrect

    Hello kavyaparuchuri,

    Which communication protocol/driver are you using?
    Is it possible that the timestamp shown is set by PLC?
    zenon can work with two timestamps. One internal which is set by the driver once a value is recieved and one external which is transmitted by PLC/IED if the communication protocol supports that.

    Regards,
    Felix

  3. #3
    Join Date
    05.02.2019
    Posts
    2

    Default Re: Alarm raised time is incorrect

    Quote Originally Posted by felixst View Post
    Hello kavyaparuchuri,



    Which communication protocol/driver are you using?

    Is it possible that the timestamp shown is set by PLC?

    zenon can work with two timestamps. One internal which is set by the driver once a value is recieved and one external which is transmitted by PLC/IED if the communication protocol supports that.



    Regards,

    Felix

    Dear Felix,

    Thank you for your reply. We are using ABB AC500 Driver. Tags are imported by configuring this driver in zenon driver configuration. The actual local time is matching with the PLC time (this has been checked in the Automation Builder PLC Hardware configuration page). But the alarm raised time is not matching with the local time shown in PLC. What could be the reason for this? And how to correct the same?

    Please find attached images for reference. The alarm acknowledged time shown in picture is the actual correct time. As you can see, the Alarm raised time is faulty.

     
    Attached Thumbnails Attached Thumbnails ZENON_DRIVER.PNG   ZENON_ALM_REC_TIMINGS.jpeg  

Similar Threads

  1. Error - The parameter is incorrect
    By Shubham Ghatwal in forum straton / zenon Logic
    Replies: 2
    Last Post: 24th February 2018, 07:33
  2. Send control when unack alarm is raised
    By HMIdeveloper123 in forum zenon Energy Edition
    Replies: 5
    Last Post: 15th March 2017, 17:54
  3. Problems with alarm list and alarm time
    By dario in forum zenon Supervisor
    Replies: 4
    Last Post: 9th November 2012, 13:52
  4. Having just one alarm line with the last time stamp
    By hamid in forum zenon Supervisor
    Replies: 3
    Last Post: 27th April 2011, 23:26
  5. InitInstance(): The parameter is incorrect.
    By wolfgangm in forum zenon Supervisor
    Replies: 0
    Last Post: 19th August 2009, 07:32

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •