Showing results 1 to 2 of 2

Thread: DynamicProperty bei Send Mail Funktion wird nicht übernommen.

  1. #1
    Join Date
    26.07.2011
    Posts
    123

    Unglücklich DynamicProperty bei Send Mail Funktion wird nicht übernommen.

    Hallo,

    ich versuche den Text einer Send Mail Funktion vor dem Versenden abhängig vom Alarm zu bearbeiten. Ich nutze hierfür C#.
    Wenn ich es richtig sehe ist der Grenzwerttext so zu erreichen:

    m_Project.FunctionCollection["FU_Send_Alarm_Mail_Grenzwert_" + (i + 1)].SetDynamicProperty("Filter[0].ConstText", "!!!Automatische Benachrichtigung!!!")

    Wenn ich danach mit dem Befehl 

    GetDynamicProperty("Filter[0].ConstText").ToString() 

    prüfe, wird mir mein Text angezeigt.

    Danach führe ich die Funktion mit 

    m_Project.FunctionCollection["FU_Send_Alarm_Mail_Grenzwert_" + (i + 1)].Execute();

    aus. Wenn die Mail ankommt ist aber immer der im Editor eingetragene Text in der Mail.
    Ich hab keine Idee was ich hier noch machen könnte.
    Ich hoffe hier hat jemand eine Idee.

    Gruß Tobias
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

  2. #2
    Join Date
    26.07.2011
    Posts
    123

    Default Re: DynamicProperty bei Send Mail Funktion wird nicht übernommen.

    Hier die Lösung:
    Ich weiß zwar nicht genau warum es so funktioniert, weil ich den Wert von .ConstText ja vorher auch schon auslesen konnte, aber was soll's.

    Scada.AddIn.Contracts.Function.IFunction myFunc = null;

    myFunc = m_Project.FunctionCollection["FU_Send_Alarm_Mail_Grenzwert_" + (i + 1)];

    myFunc.CreateDynamicProperty("Filter[0].ConstText");

    myFunc.SetDynamicProperty("Filter[0].ConstText", "!Automatische Benachrichtigung!");
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

Similar Threads

  1. Send COMTRADE in an e-mail
    By jose.torres@indexum.com in forum zenon Energy Edition
    Replies: 2
    Last Post: 31st May 2019, 08:18
  2. ActiveX wird nicht angezeigt
    By jenny in forum zenon Supervisor
    Replies: 4
    Last Post: 14th March 2014, 12:41
  3. Replies: 2
    Last Post: 26th February 2014, 14:05
  4. Replies: 2
    Last Post: 20th November 2013, 09:36
  5. VBA Makro wird nicht Abgearbeitet
    By philipp.muehlberger@nat.eu in forum VBA
    Replies: 9
    Last Post: 27th September 2011, 09:58

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •