Showing results 1 to 3 of 3

Thread: OPC communication issue

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    02.11.2018
    Posts
    5

    Default OPC communication issue

    Hello,

    I am using Zenon 7.60 build 56016. I am trying to communicate with opc server, so I have added opc UA client driver. I am able to browse opc server variables but variable values are not updating. There are no red dots on screen which indicates communication loss.
    I have checked log files for it is showing some errors.

    Error - XML Type dictionary XML parsing error.

    Please find following screenshot for reference.


    Attached Thumbnails Attached Thumbnails opc.JPG  

  2. #2

    Default Re: OPC communication issue

    Hello sachin,

    The error regarding the XML parsing of the type dictionary does not necessarily have to be the reason why the communication does not work. Another obvious reason why the communication does not work, cannot be immediately seen from the screenshot.

    From the screenshot I can see that an attempt to write a variable fails, due to incorrect access rights. Possibly this variable is read only or read only for the user used to initiate the connection.

    Please configure full (deep debug) logging of the OPC UA client driver using the diagnosis viewer and if possible perform a network packet capture using wireshark, and provide the log files and the network capture to your local COPA-DATA support, for further assistance!

    Best regards,
    Mark

  3. #3
    Join Date
    02.11.2018
    Posts
    5

    Default Re: OPC communication issue

    Thanks for your immediate reply...

    some variables are read only that's why there are access write errors in log file. There is problem with reading variable values it is observed that is is showing constant value 1 to variables. Also there is error reading type dictionary - parsing XML [ns=0, i=7617]


    I have checked with multiple opc clients...variable values are updating properly.
    Once I will check by appling deep debug.

Similar Threads

  1. Zenon to Zenon Logic communication issue
    By joelprasad in forum zenon Supervisor
    Replies: 1
    Last Post: 23rd February 2019, 18:03
  2. Replies: 3
    Last Post: 11th September 2018, 13:00
  3. DNP_TG Issue
    By yara in forum Drivers
    Replies: 1
    Last Post: 20th July 2016, 15:01
  4. Pingstate issue
    By whitetaru in forum zenon Network
    Replies: 5
    Last Post: 21st March 2014, 11:49
  5. OPC Tag issue
    By shikra in forum Drivers
    Replies: 2
    Last Post: 20th November 2013, 09:33

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •