Showing results 1 to 7 of 7

Thread: S71200 communicatin problem

  1. #1
    Join Date
    28.03.2018
    Posts
    53

    Default S71200 communicatin problem

    Hi,

    I have established a communication with siemens S71200(via S7TCP driver) from Zenon 8.0.If there is a small communication drop the connection is completely failed and it is not reconnecting only if I go to editor and open close the driver properties its working again. May I know the reason or solution for this

    Regards
    Sandeep

  2. #2
    Join Date
    25.06.2012
    Posts
    155

    Default Re: S71200 communicatin problem

    Hello Sandeep,

    I will hypothesize what can be causing the behavior depicted, but please note, if this does not help you, I strongly recommend you to contact your local support or sales representative.

    After the connection break, it can happen that the S7TCP32 driver is using the IP address of the primary connection, but the TSAP of the secondary connection that is not valid, e.g. it does not exist in the controller.

    Note that the IP and TSAP are independent configurations, so that:
    - if an alternative IP is configured, it is used.
    - if an alternative TSAP is parameterized, it is used.
    - by default, the S7TCP32 driver sets the secondary TSAP = primary TSAP.

    To resolve the issue, if it is not being used the secondary connection, you can remove the respective TSAP:



    Thank you very much.

    Best regards,
    David Cerdeira
    Attached Thumbnails Attached Thumbnails 2019-06-21_10h00_00.png  

  3. #3
    Join Date
    28.03.2018
    Posts
    53

    Rotes Gesicht AW: S71200 communicatin problem

    Dear David,

    Issue solved,,,Thank you

    Regards
    Sandeep

  4. #4
    Join Date
    01.02.2016
    Posts
    8

    Default Re: S71200 communicatin problem

    Hi all.
    I have the similar situation.
    But, how we can chack if driver use primary or secondary configuration?
    Is there any possibility to force connection to switch to secondary?

  5. #5
    Join Date
    25.06.2012
    Posts
    155

    Default Re: S71200 communicatin problem

    Dear milosh,

    The S7TCP32 driver does not inform in the runtime about the current connection used, so that it switches automatically to the alternative connection when the current connection is interrupted (e.g. PLC not reachable).

    In any case, during project engineering phase you can use a help of Diagnosis Viewer as this tool allows you to watch online and get very detailed logs of all zenon related processes, including the S7TCP32 driver. With the default settings, a driver only logs error information, but Diagnosis Viewer also allows to enhance the diagnosis level to "Debug" and "Deep Debug" and see all other important tasks and events.

    Documentation references:

    Manual > Tools > Diagnosis Viewer
    S7TCP32 > Error analysis > Analysis tool

    On the other hand, Windows Resource Monitor app also gives you a very good live insight of the overall OS resources, including network connections established. When filtering to the S7TCP32 process, you can find detailed information about the respective connections established in the Network tab, e.g. target PLC IP address.

    Good luck.

    Best regards,
    David Cerdeira

  6. #6
    Join Date
    01.02.2016
    Posts
    8

    Default Re: S71200 communicatin problem

    Quote Originally Posted by david.cerdeira View Post
    Dear milosh,

    The S7TCP32 driver does not inform in the runtime about the current connection used, so that it switches automatically to the alternative connection when the current connection is interrupted (e.g. PLC not reachable).

    In any case, during project engineering phase you can use a help of Diagnosis Viewer as this tool allows you to watch online and get very detailed logs of all zenon related processes, including the S7TCP32 driver. With the default settings, a driver only logs error information, but Diagnosis Viewer also allows to enhance the diagnosis level to "Debug" and "Deep Debug" and see all other important tasks and events.

    Documentation references:

    Manual > Tools > Diagnosis Viewer
    S7TCP32 > Error analysis > Analysis tool

    On the other hand, Windows Resource Monitor app also gives you a very good live insight of the overall OS resources, including network connections established. When filtering to the S7TCP32 process, you can find detailed information about the respective connections established in the Network tab, e.g. target PLC IP address.

    Good luck.

    Best regards,
    David Cerdeira


    Thanks a lot. I will try. and inform about solution.

  7. #7
    Join Date
    01.02.2016
    Posts
    8

    Default Re: S71200 communicatin problem

    Hello all.
    I made office test.
    Configuration:
    Zenon 7.60 Supervisor, with two Siemens PLCs which use one S7TCP32 comm. driver.

    I will try two scenarios:
    1. Secondary connection parameters does not include IP address but have Local TSAP same as Primary connection and different Remote TSAP.
    Start runtime, and after some time, disconnect cable from PLC2. zenon detects that connection is lost. On Windows resource monitor (S7TCP network activity) I'm wait to Send/Receive packets go down to 0 B/sec. Connect cable again to PLC2, but after 10-15min connection is not re-established.

    2. Delete Secondary connection parameters for both of my Siemens PLCs.
    Start runtime, and after some time, disconnect cable from PLC2. zenon detects that connection is lost. On Windows resource monitor, I'm wait Send/Receive packets to decrease to 0 B/sec.
    Connect cable again to PLC2, and connection to PLC2 was established after max. 30 sec.

    Conclusion:
    In both cases, during PLC2 connection drop, connections to other PLCs (in my case PLC1) was periodically interrupted!!!
    After re-established connection to PLC2, communication with PLC1 works correct!!!
    This was not be the problem if we use two drivers S7TCP32 for every PLC, for sure.

    Soulution for the communication problem:
    Problem is definitely parameters which define Secondary connection.
    All fields for Secondary connection shoul be empty!

    Now, I should to check this solution on site, and see if this changes will resolve my problem.

    Best regards,
    MK
    Last edited by milosh : 29th August 2019 at 13:12

Similar Threads

  1. S71200 error
    By sandeep2018 in forum zenon Supervisor
    Replies: 5
    Last Post: 2nd October 2018, 12:46
  2. problem s7tcp32 driver problem when adding new variables
    By martinrelayer in forum zenon Supervisor
    Replies: 5
    Last Post: 1st June 2018, 18:39
  3. User managment Problem, Snapshot relativ Problem
    By jusufs in forum zenon Supervisor
    Replies: 4
    Last Post: 13th September 2010, 23:06

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •