Showing results 1 to 3 of 3

Thread: Zenon V8.00 - Recipe name is empty

  1. #1
    Join Date

    Default Zenon V8.00 - Recipe name is empty

    Dear Smart people of the forum!

    We are working on a Zenon Supervisor project lately, because we need to do some update here and there.

    The project was created many years ago and the origin is unknown. Through the years, the project has been updated multiple times.

    The project has 12 pre-configured recipes and we use those to save production settings but this function has some issues lately.
    The problem is related to one of the recipe. That recipe has no name, it is an empty string. When I try to change its name then zenon editor crashes with an unhandled exception message.
    If I try to delete that recipe then everything looks okay except the system does not delete the recipe.
    When I run a function in runtime which is related to this recipe, then the runtime ends with the unhandled exception message.

    I wonder, is anyone faced something similar to this? Is there a way to repair this recipe or delete it somehow?

    Any help would be much appreciated.

    Best regards,
    Zoltan Pasztor

  2. #2
    Best Answer

    Default Re: Zenon V8.00 - Recipe name is empty

    Hello Zoltan Pasztor,

    Thanks for your post and welcome to the forum!

    What you could try (create a backup of the project first of course)

    - XML export of the recipe groups in the editor
    - delete the recipe group in the editor
    - XML import of the previously exported XML file
    -- on import, any recipe with an empty string will no longer be created and an error will be logged in the output window

    If after import you have the recipe without a name again, it could also be that the name consists of a non-printable ascii character. In this case you can try and rename the recipe by editing the XML file prior to the import (RecipeName field)

    Best regards,

  3. #3
    Join Date

    Default Re: Zenon V8.00 - Recipe name is empty

    Dear Mark,

    Thank you for your response.
    I could solve the problem with your help however I had to take extra actions.

    1. Exported all the recipes.
    2. Deleted all the recipes in the project. - I could not delete the recipe without the name.
    3. Import the recipes from xml. - This was funny because I could import the one without the name. So I ended up with two recipes without a name. (During the import, I got a message: "Please enter an identification."
    4. I was able to give a name to one of the nameless recipes and I could delete that one.
    5. I was adding and deleting variables to/from the other nameless recipe.
    6. When I deleted the values from the damaged recipe then zenon editor threw an unhandled exception. The editor closed.
    7. When I restarted the editor, I didn't see any recipe in the project. (The rest of the project was still fine.)
    8. I imported the recipes again from xml and gave a name to the nameless recipe and everything worked fine.

    I will run a few more test when I have time for that, but for now all the recipes are back in operation.

    Thank you for your help again.

    Best regards,
    Zoltan Pasztor
    Last edited by ZoltanPasztor : 3rd April 2019 at 07:29

Similar Threads

  1. Recipe value
    By scadavmesnik in forum zenon Supervisor
    Replies: 1
    Last Post: 13th September 2012, 00:13
  2. Recipe table
    By scadavmesnik in forum zenon Supervisor
    Replies: 1
    Last Post: 6th August 2012, 23:20
  3. RGM actual recipe
    By scadavmesnik in forum zenon Supervisor
    Replies: 1
    Last Post: 8th July 2012, 23:56
  4. Empty Workspace
    By bernhardf in forum zenon Supervisor
    Replies: 0
    Last Post: 20th May 2010, 13:54
  5. Empty Cross Reference List
    By mastr in forum zenon Supervisor
    Replies: 3
    Last Post: 2nd June 2009, 15:49

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts