Showing results 1 to 3 of 3

Thread: Error while giving open command ti the RTU IEC 608710 104 Protocol

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    10.05.2017
    Posts
    68

    Frage Error while giving open command ti the RTU IEC 608710 104 Protocol

    Hello Team,
    I am not able to send open command to the RTU in IEC 60870 protocol from the SCADA. I am able to send the close command though.
    I tried the same thing using a IEC 104 simulator and I was able to send both the commands open and close. 
    While trying to send open command from SCADA I am getting the following error in Diag viewer. And following error in RTU (Screenshot attached for both)

    Please suggest what could be the issue.
    Its a double point command.
    T46 is the point type.
    Attached Thumbnails Attached Thumbnails 60870 ziv.JPG   rtu.JPG  
    Regards,
    Joel

  2. #2
    Join Date
    01.07.2008
    Location
    Salzburg, AT
    Posts
    795
    Best Answer

    Default Re: Error while giving open command ti the RTU IEC 608710 104 Protocol

    Make sure this T46 variable in zenon has data type USINT (and not BOOL). If it is BOOL then the iec870 driver is not using DPI/DPC mapping, so by set value 0 - sends DPC=00b (a not permitted value for DPC), by set value 1 - DPC=01b (open).

  3. #3
    Join Date
    10.05.2017
    Posts
    68

    Daumen hoch Re: Error while giving open command ti the RTU IEC 608710 104 Protocol

    Quote Originally Posted by ursulak View Post
    Make sure this T46 variable in zenon has data type USINT (and not BOOL). If it is BOOL then the iec870 driver is not using DPI/DPC mapping, so by set value 0 - sends DPC=00b (a not permitted value for DPC), by set value 1 - DPC=01b (open).
    Thank You Ursula.


    Regards,
    Joel

Similar Threads

  1. Replies: 3
    Last Post: 14th February 2018, 09:48
  2. Aditional command butons in command processing screen
    By Joulzer in forum zenon Energy Edition
    Replies: 8
    Last Post: 6th February 2017, 09:52
  3. IEC-101 serial Protocol
    By navaneet in forum Drivers
    Replies: 2
    Last Post: 27th August 2014, 08:21
  4. Sending command with IEC850 and communication error
    By nmblanquart in forum zenon Network
    Replies: 2
    Last Post: 24th October 2012, 08:37
  5. Open database error
    By jan1024 in forum zenon Supervisor
    Replies: 13
    Last Post: 30th November 2009, 16:11

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •