Showing results 1 to 5 of 5

Thread: 3S v3 Driver settings

  1. #1
    Join Date
    26.02.2014
    Posts
    34

    Default 3S v3 Driver settings

    I am trying to get a Zenon 3S V3 driver to talk to a Festo CPX-CEC-C1.
    Can anyone help with the settings?
    I am using ARTI V2.3.
    I need to know which transport setting to use and which port number.
    I'm not even sure what the term "port number" means!
    Thanks
    Last edited by mjackson : 16th July 2018 at 13:53

  2. #2
    Join Date
    30.05.2007
    Posts
    105
    Best Answer

    Default Re: 3S v3 Driver settings

    Hello,

    It should work with the following Connection settings:

    Type: ARTI
    Version: V2.3
    Primary Node Address: IP Address if the Controller Format e.g.: 192.168.1.3
    Transport: TCPL4
    Port: 1200
    Target ID:0
    TCPL2 Buffer Size: 1500
    Timeout: 5000 
    Retries: 3

    Please also take into account that the symbols are embedded in the PLC project.
    That means that the variable names are also stored in the PLC codefiles.
    You can enable this in the CODESYS Options. You find them in the Menu 'Project'-->'Options'
    see also the attached screenshot.



    good Connections,
    Markus 


    Attached Thumbnails Attached Thumbnails festSymbol.jpg  

  3. #3
    Join Date
    26.02.2014
    Posts
    34

    Default Re: 3S v3 Driver settings

    Thank you for your help. Unfortunately it does not communicate.
    Maybe the format of variables is wrong. For example, under Global Variables in the PLC, I have a test variable simply called c
    So in the Zenon I have made a variable and put only the letter c in General>identification and also Addressing>Symbolic address of my variable. Is this enough, or do I need more information in here?
    Or maybe the problem is something else.
    Any ideas you can give would be good.
    Thank you

  4. #4
    Join Date
    30.05.2007
    Posts
    105

    Default Re: 3S v3 Driver settings

    You could try and browse the variables from the PLC directly instead of creating them manually.
    in the section Driver select the 3S_V3 Driver and Right-Click to open the contextual menu, then choose 'Import variables from driver...'.
    Select the PLC Connection you want to browse the variables from.
    If no variables appear in the following Dialog, it could be that the Symbols are not embedded in the PLC.

    Also a good source if it is not working: the diagnosis Viewer. 
    What Error occours?
    see also: https://forum.copadata.com/showthread.php?7455-How-to-troubleshoot-driver-issues-the-right-way

  5. #5
    Join Date
    26.02.2014
    Posts
    34

    Default Re: 3S v3 Driver settings

    I have now got the driver working correctly. Thank you for your help.

Similar Threads

  1. RGM column settings
    By scadavmesnik in forum zenon Supervisor
    Replies: 2
    Last Post: 12th June 2012, 05:25
  2. Please help me with settings IEC870
    By focus in forum zenon Energy Edition
    Replies: 2
    Last Post: 10th January 2012, 14:27
  3. Please help me with settings IEC870
    By focus in forum Drivers
    Replies: 2
    Last Post: 10th January 2012, 14:27
  4. Settings for report printer
    By bojan in forum zenon Supervisor
    Replies: 2
    Last Post: 26th April 2011, 17:03
  5. Settings for the aml don't take any effect
    By matthias.zoellner in forum zenon Supervisor
    Replies: 2
    Last Post: 14th August 2008, 12:22

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •