Do you have installed/activated .NET Framework 3.5? It is needed for the SQL-Server installation.