I'm trying to connect to a Codesys v.3 PLC (Festo CPX-CEC-C1-v3 and Festo CECC) from Zenon Supervisor 7.20 sp 0 build 18778 installed on Win 7 x64 sp1 Ultimate. Codesys 3.5 incl. Gateway, SoftPLC and everything else is installed on the computer.
This is a fresh Windows installation, with only Zenon & Codesys installed, Windows firewall is is off, Windows defender real time scanning is off.

Trying to add 3S v3 driver for PLC Handler to the project results in the following error
zenon Supervisor
3S_V3.EXE: Module could not be loaded!
(The last error : 0x00000715)
I manually copied PLCHandlerDll.dll to both C:\Windows\System32 and C:\Windows\SysWOW64, tried starting the Startup Tool 'as Administrator', tried both 32 and 64 bit versions of the editor - nothing helps, I always see the above error.

Trying to add Codesys SoftPLC driver results in
3S_32.EXE: Module could not be loaded!
(The last error : 0x00000715)

What 0x00000715 means and do I need anything else besides PLCHandlerDll.dll to connect to a Codesys v3 PLC ?

Then I decided to try with OPC UA which the PLCs also support.
Adding OPC UA driver and importing the variables from both PLCs was OK - all the variables were imported OK, and their types correctly recognized. But in the runtime, the variable values are not visible - there's just a small red square instead.
An OPC UA browser installed on the same PC (Unified Automation UaExpert) connects to both PLC's and I can view / change variables without any problems.

Any hint for OPC UA?

I did all the above on a 2nd computer, also Win7 x64 Ultimate sp1, and had exactly the same errors & problems.

I'm testing in demo mode (no dongle), could this be the problem?

Thanks for any suggestions.