Showing results 1 to 5 of 5

Thread: zenDBsrv

  1. #1
    Join Date

    Default zenDBsrv

    Hi everyone,

    I tried to restore a project to Zenon Energy Edition 7.50 which was done by a colleague and I wanted to test the driver configuration. However, when I did it, I received the error that it could not establish a connection to the project due to zenDBsrv not running. When I first installed Zenon on this work laptop, I had some problems with the database since there already was a Zenon SQL 2012 Database, but as I recall, I managed to install it correctly and start the runtime and establish a connection to an IED. Some time has passed and I couldn't find zenDBsrv on the services window. 

    If anyone could help me find out what the problem is and what I could do to solve it, I'd very appreciate it.


  2. #2
    Join Date

    Default Re: zenDBsrv

    Hi mehrdad6687,

    Try to Register files again by clicking "Standard" button in "Startup Tool". Hope this will solve your issue.

    Attached Thumbnails Attached Thumbnails Register.png  

  3. #3
    Join Date

    Default Re: zenDBsrv


    Thanks for the answer. But I tried this and I could see the zenDBsrv open in processes on task manager but still the service is not open yet and I cannot restore the project. Is it worth to install Microsoft SQL again and try the services?

    I don't want to have to reinstall Zenon since now I have another issue trying to install it on a different windows 10 PC and I keep getting the attached error message. I've made sure the windows is updated completely so I don't know what is the problem.

    Thanks again for the help.


    Attached Thumbnails Attached Thumbnails Zenon error message 32 bit.jpg  

  4. #4
    Join Date
    Salzburg, AT

    Default Re: zenDBsrv

    The errors about mfc-dll are comming because on your Windows you are missing correct Visual Studio Redistributables for 64 and 32 bits (on 64bits system you need to install both). There was some issue in Windows. Unfortunately, I don't remember details anymore (was more as a year ago), maybe some else may add more hints here.

  5. #5
    Join Date

    Default Re: zenDBsrv


    Ursula is right, the missing mfc140u.dll probably means that the Visual Studio redistributable version 2015 is not well installed on your PC.
    There was an issue some time ago, but now it has been fixed by Microsoft. Trying to install the 32 bit version of the Redistributable automatically "removed" the 64 bit version. But this should not happen anymore.

    First of all, if you are running an x64 PC, check in your installed programs that the Microsoft Visual C++ 2015 Redistributables x86 and x64 are well installed. If not, recover it from the Microsoft website or from the zenon CD and install it

    Have a nice day,

Similar Threads

  1. Zenon energy edition 7.50 SP0 zendbsrv is not running
    By mehrdad6687 in forum Engineering Studio & Service Engine
    Replies: 2
    Last Post: 22nd December 2016, 14:45
  2. Zenon 7 registration error with "ZenDbSrv is running" message
    By stolyarov_as in forum zenon Service Engine Supervisor
    Replies: 5
    Last Post: 7th June 2013, 11:47

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts