Page 1 of 2 1 2 LastLast
Showing results 1 to 10 of 11

Thread: Internet Explorer 8.0 for Web-Client ?

  1. #1
    Join Date
    23.04.2009
    Posts
    56

    Default Internet Explorer 8.0 for Web-Client ?

    Hi,

    My Web-Server and Web-Client work well with Internet Explorer 7.
    But these days, you know, because of the automatic update of the Microsoft, some of ours browser is changed to Internet Explorer 8.0. Then, when we start the Web-Client by Internet Explorer 8, it doesn't work.. An error window is shown :


    Message for webpage

    Microsoft Internet Explorer : 4.0 (............) is not supported !


    But, sure, my browser is IE8 instead of IE4! So how can I resolve this problem?

  2. #2
    Join Date
    30.05.2007
    Location
    Salzburg
    Posts
    879

    Default Re: Internet Explorer 8.0 for Web-Client ?

    At IE8 there is a new special security setting which has to be disabled. Unfortunately I dont know it by heart (i can check this on monday).

    We could successfully could run the WebClient with 6.22 SP1 on IE8 (i didn't do tests with older zenOn versions but they should behave the same).

    Regards,
    Herbert

  3. #3
    Join Date
    23.04.2009
    Posts
    56

    Default Re: Internet Explorer 8.0 for Web-Client ?

    Thank you a lot for you reply. Now I am soothed. See you monday!

  4. #4
    Join Date
    30.05.2007
    Location
    Salzburg
    Posts
    879

    Default Re: Internet Explorer 8.0 for Web-Client ?

    I now could check the setting which should be deactivated:
    -> its the "Enable memory protection to help mitigate online attacks" setting in Internet Options -> Advanced tab (need to run as with admin permissions to set this setting)

    If this is enabled we encounterd a problem if the WebClient runs on Windows Vista and VBA is activated (no problems when using on Windows XP or if VBA is deactivated)

    Note: Internet Explorer 8 is not official support by the zenOn WebClient yet
    -> this will be probably in the next ServicePack of zenOn 6.22 or in the version after zenOn 6.22

    So if the error message still occurs if the above mentioned setting is deactivated you should downgrade to Internet Explorer 7.

    Regards,
    Herbert

    ps: at your own risk you can add the "MSIE 8.0" entry within the "browsercheck.js"

  5. #5
    Join Date
    23.04.2009
    Posts
    56

    Default Re: Internet Explorer 8.0 for Web-Client ?

    Hi, thanks for your reply, now I have modified the file "browsercheck.js", and the problem is resolved.

    I really appreciate you guys at this forum for Product-Support information. I think this is also a key factor in the success of ZenOn.

  6. #6

    Default Re: Internet Explorer 8.0 for Web-Client ?

    Another possibility is to use the compatibility mode of the IE 8.0.
    With the compatibility mode enabled the IE 8.0 presents itself as IE 7.0 like visible in the following screenshots.

    IE 8.0 with compatibility mode
    Click image for larger version

Name:	ScreenShot021.jpg
Views:	67
Size:	27.5 KB
ID:	447

    IE 8.0 without compatibility mode
    Click image for larger version

Name:	ScreenShot022.jpg
Views:	40
Size:	34.0 KB
ID:	448

    Means if the javascript file browsercheck() keep untouched and the compatibility mode of the IE 8.0 is active ist also works!

  7. #7
    soccorss Gast

    Default Re: Internet Explorer 8.0 for Web-Client ?

    read the suggestions given by you all but i am still facing the same problem. Any more ideas?? Or is there anyone who can deal with this then i can surely give you credentials!!

  8. #8

    Default Re: Internet Explorer 8.0 for Web-Client ?

    @soccorss

    If you are having issues, please send an e-mail to your local support, for them to help you identify the problem.

    Meanwhile, if you post in the forum, please refrain from posting links to other sites at your posts, to avoid being banned from the forum, and your posts being deleted.

  9. #9
    nurul Gast

    Rotes Gesicht Re: Internet Explorer 8.0 for Web-Client ?

    Hi..

    Just a quick one, can the IE 9.0 supporting web-client?

    -Nurul-

  10. #10
    Join Date
    20.08.2009
    Posts
    293

    Default Re: Internet Explorer 8.0 for Web-Client ?

    Quote Originally Posted by nurul View Post
    Hi..

    Just a quick one, can the IE 9.0 supporting web-client?

    -Nurul-
    Hi,

    yes it works (although it is not officially tested).

    The same setting as in IE8 has to be disabled to get it working properly, see posts above.

    Regards
    Last edited by bernhardf : 1st June 2011 at 08:29

Similar Threads

  1. Replies: 5
    Last Post: 30th July 2018, 10:45
  2. Client - Server communication problems
    By dragosmoss in forum zenon Network
    Replies: 8
    Last Post: 13th May 2009, 14:38
  3. Web Client 620 crashes on startup.
    By zw1 in forum Editor and Runtime Setup
    Replies: 4
    Last Post: 20th April 2009, 14:23
  4. The web client does not open the zenon project...
    By shahrzad in forum Webserver/Webclient
    Replies: 10
    Last Post: 8th October 2008, 13:32
  5. Only one client is being licenced with a network dongle!
    By wolfgangm in forum zenon Network
    Replies: 0
    Last Post: 10th August 2007, 12:36

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •