Showing results 1 to 5 of 5

Thread: Numerical Value display problem

  1. #1
    scotttee Gast

    Default Numerical Value display problem

    I've got settable numerical value elements that display and set values correctly. But the numerical values that are display only, don't work correctly. At runtime, all that is displayed is 0** or 1**. What am I doing wrong?

  2. #2

    Default Re: Numerical Value display problem

    "**" being displayed in a numerical element means there is an overflow. (value is greater than configured)


    Please check your settings for the value adjustment in the properties window for the variable itself: check the signal resolution and the measuring range.

    How did you configure "display only"? By deactivating "set values active"?

  3. #3
    scotttee Gast

    Default Re: Numerical Value display problem

    Yes, I disabled "set values active". I had to delete the variable and recreate it. It now works.

    I have one question regarding displaying variables: Is there a way to show the variable modified by a constant? Or use an expression/equation? For example: StepNumber+1. (StepNumber being the variable.)

  4. #4

    Default Re: Numerical Value display problem

    take a look at the mathematics driver. These variables do not count as tags, and you can perform comprehensive mathematical calculations, based on variables, and show the output as the value of the mathematical formula.

    This would also not affect the original variable from the PLC. (otherwise you could also add +1 in the PLC)

  5. #5
    scotttee Gast

    Default Re: Numerical Value display problem

    Got it. Thanks Mark.

Similar Threads

  1. Limit Text - Display ID or Name of variable
    By craigdouglas in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 5
    Last Post: 9th December 2008, 15:23
  2. display last open picture
    By dak2483 in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 3
    Last Post: 5th September 2008, 18:57
  3. Display Text Value
    By lengele in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 2
    Last Post: 18th December 2007, 13:50
  4. Display trend on Windows CE devices
    By sebastiank in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 0
    Last Post: 27th August 2007, 08:57

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •