Showing results 1 to 6 of 6

Thread: Missing .CMP files

  1. #1
    scotttee Gast

    Default Missing .CMP files

    When I do 'Project remote transport->Start runtime', a message appears on the CE device stating that recipe.cmp and password.cmp are missing. I've tried modifying the project.ini file to change the NOOVERWRITE for these files to 0 (zero). No dice. How can I make sure these files are transported to the CE device?

  2. #2
    scotttee Gast

    Default Re: Missing .CMP files

    I figured out how to get these files transferred. Under 'RT Changeable Data' in the General project properties: Uncheck "Do Not Generate and Transfer".

    Now I get BRTCP32.dll - Could not load module.(Last error = 0x7e)

    Any ideas?

  3. #3
    Join Date
    30.05.2007
    Location
    Salzburg
    Posts
    879

    Default Re: Missing .CMP files

    Hello,

    I'm not an expert on drivers nor for CE issues but as far as I can see from the driver description (you can find this in the driver selection dialog) this driver is not available for CE devices...

    Below the driver description:

    Description:
    Driver for B+R Burklimat or B+R System 2000 PLCs. Needs no PVI software but a special handling-modul in the PLC witch can only orderd from B+R . (www.br-automation.com)

    Supported PLC types:
    B+R System 2000 and B+R Burklimat

    Supported connection types:
    Ethernet

    Supported communication protocols:
    B+R TCP

    The driver is available for the following operating systems:
    Windows 2000, XP, Vista, Server 2003, Server 2008


    The driver is available for the following CE platforms:


    Necessary additional hardware on the PC:
    Standard network card

    Necessary additional software on the PC:
    -

    Necessary additional hardware on the PLC:
    -

    Necessary additional software on the PLC:
    Needs special software in the B+R System 2000 PLC


    Driver features:
    RDA supported: NO
    RDA String: NO
    Address based: YES
    Name based: NO
    Blockwrite: NO
    Serial logging: NO
    Error file: YES
    Realtime stamping: YES
    Modem supported: NO
    Polling: YES
    Spontaneous: YES
    Browsing online: NO
    Browsing offline: NO

    Driver EXE name: BrTcp32.exe


    Regards,
    Herbert

  4. #4
    Join Date
    05.03.2009
    Posts
    23

    Default Re: Missing .CMP files

    Hello!

    I have similar difficulties but on ordinary PC platform: recipe.cmp and password.cmp (and some other files) are not transefered during remote transport and remote runtime start could not be started. When I copy those two files manualy to the target computer, runtime starts without the problems. Is that usual behaviour when doing remote transport? I tried to put those two files in remote transport path, but with no success.

    Best regards,
    Gregor

  5. #5
    Join Date
    05.03.2009
    Posts
    23

    Default Re: Missing .CMP files

    Issue is solved as described in thread
    http://www.copadata.com/forums/showt...ight=cmp+files

    Bestr regards,
    Gregor

  6. #6
    christopherpara Gast

    Default Re: Missing .CMP files

    in the future version of zenon this problem with *.cmp file will not exist!

Similar Threads

  1. HELP: I can not save dbf files in excel!
    By markclemens in forum zenon Supervisor
    Replies: 1
    Last Post: 12th June 2008, 07:11
  2. How to get the runtime files on a CE device
    By sebastiank in forum zenon Operator
    Replies: 1
    Last Post: 19th November 2007, 13:18
  3. values of my mathematics driver suddenly missing
    By markclemens in forum zenon Network
    Replies: 0
    Last Post: 20th August 2007, 12:10

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •