Showing results 1 to 9 of 9

Thread: manche Benutzer zeitweise nicht anmeldbar

  1. #1
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Unglücklich Benutzer-Anmeldung nicht mehr möglich nach Update von 7.11 auf 7.50

    Hallo zusammen,

    habe gerade eben mein zenon Supervisor 7.11-Projekt auf zenon 7.50 upgedatet. Hat besser geklappt als erwartet - allerdings habe ich jetzt ein Problem: das Projekt erkennt in der Runtime seinen Administrator-Zugang nicht mehr! Die normalen Benutzer können sich unverändert anmelden, aber beim Administrator behauptet es steif und fest, es sei ein unbekannter Benutzername! Ich habe die Schreibweise mehrfach überprüft, aber es hilft nichts: keine Anmeldung möglich! Ich habe beim Update definitiv NICHTS an den Projekteinstellungen oder irgendwelchen Parametern geändert! Woran kann es also liegen?
    - Ich hatte dann die Idee, ich könnte den Zugang ja "einfach mal" umbenennen, das Ganze nachladen und schauen, ob es dann geht. Aber das war eventuell eine dumme Idee: seitdem passiert bei einem klick auf den Anmelden-Button gar nichts mehr...

    Ach so, noch als Ergänzung: am webclient gelingt die Anmeldung als "Normal-Benutzer" noch, obwohl an der Runtime diesbezüglich nichts mehr geht...

    Bin wie immer für sachdienliche Hinweise dankbar!

    Viele Grüße

    Michael
    Last edited by michab : 18th July 2016 at 13:07
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  2. #2

    Default Re: Benutzer-Anmeldung nicht mehr möglich nach Update von 7.11 auf 7.50

    Hallo Michael,

    Wurden vor der Konvertierung im Editor 7.11, die Runtimedateien importiert, damit die aktuellen Benutzer aus der Runtime im Editor übernommen sind?

    Und nach der Konvertierung im Editor 7.50, einmalig die Option zum Kompilieren und Übertragen der Benutzerverwaltung, deaktiviert, (RT Änderbare Daten) und die 7.50 Runtime Dateien kompiliert und übertragen?

    Was macht der Anmelden Button in diesem Projekt? Ruft er die Funktion "Login" auf, oder öffnet es ein Bild vom Typ Login? Oder etwas anderes?

    Mfg
    Mark

  3. #3
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default AW: Re: Benutzer-Anmeldung nicht mehr möglich nach Update von 7.11 auf 7.50

    Hallo Mark,

    Quote Originally Posted by markclemens View Post
    Wurden vor der Konvertierung im Editor 7.11, die Runtimedateien importiert, damit die aktuellen Benutzer aus der Runtime im Editor übernommen sind?
    Nein. Ich wüsste allerdings im Moment auch nicht, wo und wie ich das machen soll? - Bei uns werden im Projekt Benutzerdaten nicht geändert, so dass sich da eigentlich nichts geändert haben sollte.

    Quote Originally Posted by markclemens View Post
    Und nach der Konvertierung im Editor 7.50, einmalig die Option zum Kompilieren und Übertragen der Benutzerverwaltung, deaktiviert, (RT Änderbare Daten) und die 7.50 Runtime Dateien kompiliert und übertragen?
    Nochmal nein. Alles kompiliert und übertragen, ja. Aber ohne diese Option gesondert zu berücksichtigen. Die ist bei uns - wenn ich das richtig sehe - dauerhaft deaktiviert.

    Quote Originally Posted by markclemens View Post
    Was macht der Anmelden Button in diesem Projekt? Ruft er die Funktion "Login" auf, oder öffnet es ein Bild vom Typ Login? Oder etwas anderes?
    Der Button ruft die Funktion "Login mit Dialog" auf.
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  4. #4

    Default Re: Benutzer-Anmeldung nicht mehr möglich nach Update von 7.11 auf 7.50

    Hallo Michael,

    Wenn der Checkbox für die Benutzerverwaltung in RT Änderbare Daten, in der Spalte "nicht kompilieren und übertragen" dauerhaft deaktiviert ist, wird die Benutzerinformation jederzeit kompiliert und übertragen.

    Weshalb die Login Maske nicht mehr erscheint in der Runtime, nachdem ein Benutzer umbenannt wurde und nachgeladen, jedoch am Webclient noch funktioniert und dort nicht alle Benutzer angemeldet warden können, ist mir momentan so nicht klar.

    Am besten ist es meiner Meinung nach, für diesen Fall den lokalen COPA-DATA Support zu kontaktieren.

    Mfg
    Mark

  5. #5
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default AW: Re: Benutzer-Anmeldung nicht mehr möglich nach Update von 7.11 auf 7.50

    Quote Originally Posted by markclemens View Post
    Wenn der Checkbox für die Benutzerverwaltung in RT Änderbare Daten, in der Spalte "nicht kompilieren und übertragen" dauerhaft deaktiviert ist, wird die Benutzerinformation jederzeit kompiliert und übertragen.
    Stimmt natürlich! Das habe ich gar nicht bedacht...
    Wie auch immer: zwischenzeitlich ist das login-Fenster aufgepoppt... und der geänderte Benutzer ließ sich anmelden!

    Ja, ich denke mal, ich werde das unserem Support mal mitteilen...

    Vielen Dank für die Unterstützung und viele Grüße

    Michael
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  6. #6
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Frage manche Benutzer zeitweise nicht anmeldbar

    Hallo zusammen,

    seit dem Update von zenon Supervisor 7.11 auf Version 7.50 haben wir das Problem, dass bestimmte Benutzernamen zeitweise nicht angemeldet werden können! Gibt man diese Namen ein, bekommt man die Meldung: "Ungültiger Benutzername!"
    Da wir die Benutzerverwaltung nur über den Editor betreiben, also von der Runtime aus keinen Einfluss auf Namen oder Passwörter nehmen (ein Bild vom Typ "Benutzerverwaltung" existiert nicht), kann ich mir nicht erklären, wie das passieren kann. Wie gesagt: es kommt nur zeitweise vor! Mal geht's, dann geht's wieder nicht.
    Das größte Problem dabei: zwei der betroffenen Benutzernamen sind auf das Message Control aufgeschaltet und sollen die wichtigen Störungen per SMS an Handys melden. Das tun sie aber allem Anschein nach nur dann, wenn sie zum entsprechenden Zeitpunkt auch angemeldet werden können. Die einzige Lösung scheint darin zu bestehen, neue Benutzer mit gleichen Gruppen und Rechten anzulegen und diesen die Handy-Nummern zuzuweisen. Ich finde solche Phänomene allerdings immer wieder äußerst unangenehm, vor allem, wenn sie so zufällig zu sein scheinen.
    Sollte mir also jemand verraten können, was ich da falsch gemacht habe oder wie ich es so abstellen kann, dass alle Benutzer wieder dauerhaft anmeldbar sind, fände ich das klasse!

    Viele Grüße

    Michael
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  7. #7
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default AW: manche Benutzer zeitweise nicht anmeldbar

    Zusatzbemerkung: es scheint so, als würde immer direkt nach dem Nachladen der Benutzer erst mal existieren, und dann nach einiger Zeit (ein paar Stunden, kann ich allerdings derzeit nur schwer abschätzen) nicht mehr...
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  8. #8

    Default Re: manche Benutzer zeitweise nicht anmeldbar

    Hallo Michael,

    Ich habe den Thread mit dem früheren zusammengeführt.

    An erster Stelle würde ich den lokalen Support kontaktieren. In erster Instanz habe ich keine Idee wie es zu so einer Situation kommen könnte.

    Gibt es in der Chronologische Ereignisliste Einträge zu der Benutzerverwaltung?

    Mfg
    Mark

  9. #9
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default AW: Re: manche Benutzer zeitweise nicht anmeldbar

    Oh, sorry! Dass ich das Thema zweimal gestartet habe, war mir gar nicht bewusst.
    Da war ich wohl zu sehr mit dem Problem beschäftigt... Danke fürs Zusammenführen!
    Support ist kontaktiert.

    Viele Grüße

    Michael
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

Similar Threads

  1. manche webclients zeigen nur Hintergrundfarbe
    By michab in forum Webserver/Webclient
    Replies: 2
    Last Post: 21st July 2016, 16:17
  2. Replies: 4
    Last Post: 15th July 2014, 08:15
  3. Welcher Benutzer hat welchen Alarm quittiert?
    By and12121 in forum zenon Supervisor
    Replies: 5
    Last Post: 7th May 2014, 15:08
  4. Benutzer vom Editor in RT übernehmen
    By stibi in forum zenon Supervisor
    Replies: 1
    Last Post: 22nd December 2009, 14:17

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •