Showing results 1 to 1 of 1

Thread: Treibereintrag in Elementen einer Variablenstruktur ist falsch!

  1. #1
    Join Date
    29.07.2007
    Location
    Germany
    Posts
    191

    Default Treibereintrag in Elementen einer Variablenstruktur ist falsch!

    Hallo!

    Ich verwenden in meinem C# Script im Editor die folgende Zeile:

    zoVariable.set_DynProperties("Driver", zoDriver.get_DynProperties("DriverId"));


    um die Treiberzordnung per Makro zu ändern.
    Bei einfachen Variablen funktioniert das wunderbar.

    Kommt aber eine Strukturvariable gibt es ein Problem:
    Ich passe die Variable an und die Element der Stuktur sollten ja den gleichen Treiber vererbt bekommen, dass passiert aber nicht!
    Die Elemente behalten den alten Treibereintrag und nur die Strukturvariable bekommt den neuen Treiber eingetragen (Screenshot)

    Per Hand im Editor klappt es normal, was muß ich im Script tun damit es dort auch funktioniert?

    zenon 7.11 Build24983

    Gruß, H.-P.
    Attached Thumbnails Attached Thumbnails BP_Adr.png  
    string zenon = "7.60 Build52515 / 8.00 Build52082";
    string Windows = "7 / 10 / 2012R2";
    string VMware = "Workstation / VMware ESXi";

Similar Threads

  1. Soll /Ist-Vergleich im Trendbild
    By wenzm in forum zenon Supervisor
    Replies: 1
    Last Post: 2nd December 2014, 11:57
  2. Sichtbarkeit von Elementen
    By sniggi in forum zenon Supervisor
    Replies: 3
    Last Post: 10th May 2013, 13:21
  3. Limit Text in Elementen zuweisen
    By kicker in forum VBA
    Replies: 2
    Last Post: 16th December 2008, 10:26

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •