Showing results 1 to 6 of 6

Thread: Auflösung der Zeitachse im ETM

  1. #1

    Frage Auflösung der Zeitachse im ETM

    Hallo,

    die Darstellung von Energiewerten wird immer wichtiger, eine schöne Übersicht ist daher unerlässlich. Ich stelle Energieverbräuche aktuell in Wochen-, Monats- und Jahresübersichten dar. Die Archivwerte werden immer um 00:00Uhr gebildet (Tagessumme, Wochensumme etc.).
    In der Darstellung wäre es jetzt sehr schön, wenn die Zeitachse zu den Archivwerten passen würde. In einer Woche also unten die Hauptticks immer um 00:00Uhr des jeweiligen Tages, beim Monat immer an den Montagen um 00:00Uhr und in der Jahresübersicht immer am 1. des Monats um 00:00Uhr. Gibt es eine Möglichkeit dies zu erzwingen?
    Bei einigen Kurven ist der erste Haupttick plötzlich nicht mehr im Ursprung, sondern einfach etwas später (siehe Bild) für dieses Verhalten habe ich kein Erklärung, wenn ich eine falsche Aufteilung wähle ist er plötzlich wieder im Ursprung....

    Vielleicht kann mir jemand erklären woran das liegt, und wie ich eine sauber Darstellung der Werte bekommen.

    Grüße Tobi
    Attached Thumbnails Attached Thumbnails 2015-10-19_145913.jpg  
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

  2. #2

    Default AW: Auflösung der Zeitachse im ETM

    Hallo,

    hier noch ein Beispiel was mich verwirrt. Zeitachse ist auf eine Woche eingestellt Montag bis Montag, da ich den Sonntag ja auch bis 00:00Uhr sehen möchte.
    Es werden alle Werte um 00:00Uhr aufgezeichnet es sind 7 Zeiträume für 7 Tage.
    Jetzt verschiebt sich die Zeitachse jeden Tag ein bisschen. Ganz komisch ist allerdings der letzte Wert, denn lt. Zeitachse wurde er um 23:00Uhr aufgezeichnet (deutlicher Versatz zu 00:00Uhr), was aber nicht stimmt. Wie man auch dem Cursor entnehmen kann.
    Das ist echt ärgerlich.
    Hoffe jemand kann hierzu etwas sagen, ob diese Problematik generell besteht, oder ob es ein einzelnes Problem in meinen Trends ist.

    Grüße Tobi
    Attached Thumbnails Attached Thumbnails 2015-10-20_154132.jpg  
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

  3. #3

    Default AW: Auflösung der Zeitachse im ETM

    Die Problematik besteht leider immer noch, ich kann die Zeitachse nicht dazu bringen immer im Ursprung zu beginnen.
    Hat jemand eine Idee, oder kann die Problematik nachvollziehen?

    Gruß Tobi
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

  4. #4

    Default AW: Auflösung der Zeitachse im ETM

    Habe eine Anfrage zu diesem Thema direkt an Copadata abgesetzt. Hoffe hier kommt vielleicht bald mal etwas rum.
    Anbei nochmal ein Bild in der die Problematik ersichtlich wird. ausgewählt wurde ein absoluter Zeitraum. Beginn am 01.03 und Ende 31 Tage später. So kann ich sicherstellen das meine Teilungseinheit (32) immer passt ohne das ich diese anpassen muss. Im Bild 2 das gleiche für den Februar, hier passt es. Es passt in allen Monaten nur nicht im März und im Oktober. Hier ist der erste Wert der Zeitachse einfach nicht im Ursprung.

    Zu einem ähnlichen Problem in einem anderen Tread habe ich auch noch nichts neues bekommen. Darstellung eines Jahres. Ticks immer am ersten des Monats wären toll. siehe: http://forum.copadata.com/showthread.php?t=3605
    Hat das schon mal jemand gemacht?
    Attached Thumbnails Attached Thumbnails 1_Zeitachse passt nicht.jpg   2_Zeitachse passt.jpg  
    Last edited by zero : 25th May 2016 at 10:52
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

  5. #5

    Default AW: Auflösung der Zeitachse im ETM

    Bin dem Problem wieder etwas näher gerückt....Auffällig nur der März und der Oktober machen ein Problem...Der Zeitraum wird ja immer auf die Zeitachse (31Tage angepasst) um eine optimale Darstellung zu gewährleisten. Ich denke die falsche Darstellung im März und im Oktober hängt mit der Uhrumstellung zusammen. Hier isz dann der Dargestellte Zeitraum jeweils 31 +-1Stunde....

    Gruß Tobi
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

  6. #6

    Default AW: Auflösung der Zeitachse im ETM

    Der Support konnte für die Verschiebung in den Monaten mit Uhrumstellung leider auch keine Lösung finden. Mir wurde geraten die Darstellung der Verbräuche mit dem ReportViewer zu machen. Dort gab es dann auch wieder ein paar kleine Stolpersteine was die Zeitachse angeht. Diese konnten allerdings gelöst werden.
    http://forum.copadata.com/showthread.php?t=3756
    Aktuell erscheint dies als beste Lösung.

    Gruß Tobi
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

Similar Threads

  1. Zweite Zeitachse
    By zero in forum VBA
    Replies: 2
    Last Post: 19th October 2015, 13:46
  2. Problem mit Auflösung in Zenon 7
    By sniggi in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 3
    Last Post: 31st July 2012, 14:51

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •