Page 1 of 2 1 2 LastLast
Showing results 1 to 10 of 11

Thread: 3S Arti NG Treiber - Kommunikationsproblem

  1. #1
    Join Date
    27.08.2011
    Posts
    88

    Ausrufezeichen 3S Arti NG Treiber - Kommunikationsproblem

    Hallo,

    habe folgendes Problem mit dem 3S Arti NG Treiber (Zenon Supervisor 7.20):

    manchmal, wenn die Steuerung ausfällt (Stromausfall, Schaltschrank ausgeschalten...) bekomme ich nachher keine Verbindung mehr. Das Problem lässt sich beheben indem ich die Runtime neu starte oder indem ich den Treiber stoppe und neu starte. Es scheint also am Treiber zu liegen.
    Besonders oft passiert ist es bei einem Projekt, in dem viele Treiber angelegt sind (ca. 50). Mir wurde jedoch vom lokalen Support gesagt, dass dies kein Problem sein sollte. Wenn ich nun mehrere Steuerungen zugleich neu starte, bleibt bei der einen oder anderen Steuerung der Treiber hängen!
    Aber auch bei Projekten mit einigen wenigen Treibern ist das Problem schon aufgetreten!

    Wenn man das ganze mit dem Diag Viewer analysiert, scheint es als ob die Steuerung nicht erreichbar ist. Ist aber nicht der Fall, Netzwerkverbindung funktioniert!

    Jemand eine Idee?

    Grüße

    Johannes

  2. #2

    Default Re: 3S Arti NG Treiber - Kommunikationsproblem

    Hallo Johannes,

    Grundsätzlich versuchen zenon Treiber kontinuierlich eine Verbindung zur SPS erneut aufzubauen, wenn der Treiber festgestellt hat, dass diese verloren gegangen ist.

    Wenn mehrere Verbindungen betroffen sind, passiert das bei mehrere Treiberinstanzen parallel, bei mehrere Verbindungen pro Treiber passiert das sequenziell.

    Der 3S_Arti_NG Treiber benötigt für die Verbindung zur SPS die ARTI Schnittstelle am lokalen Rechner.

    Ich kenne jetzt die Logs vom Diagnoseserver nicht, aber wenn die ARTI Schnittstelle meint, die SPS ist nicht erreichbar, dann könnte man eventuell mittels Wireshark den Netzwerkverkehr sniffen, ob für die betroffene Verbindung versucht wird, eine TCP Verbindung zur SPS zu erstellen und ob diese Erfolgreich ist.

    Mfg
    Mark

  3. #3
    Join Date
    27.08.2011
    Posts
    88

    Default Re: 3S Arti NG Treiber - Kommunikationsproblem

    Hallo,

    zusammen mit unserem lokalen Support (Italien) konnten wir das Problem letzte Woche eingrenzen. Wie auch oben vorgeschlagen haben wir Wireshark laufen gelassen und bemerkt, dass keine Kommunikation zu der betroffenen Steuerung mehr erfolgt. Das Problem scheint in der DLL von 3S zu liegen. Wenn man das Timeout in der Verbindungseinstellung des Treibers auf 30s setzt (30000ms) verbessert sich das Phänomen, es kommt aber vereinzelt immer noch zu einem dauerhaften Ausfall. Ich werde in den nächsten Tagen versuchen noch einige Tests zu machen, und werde dann berichten.

    Grüße

    Johannes

  4. #4
    Join Date
    27.08.2011
    Posts
    88

    Default AW: 3S Arti NG Treiber - Kommunikationsproblem

    Hallo,

    ich habe nun ein neues Problem mit dem Treiber...
    Bei Steuerungen, auf denen die Codesys Version 2.3.9 SP6 läuft dauert es sehr lange (mehrere Minuten) bis bei einem RT Start die Variablen angezeigt werden. Habe es auch mit einem Testprojekt mit nur einem Bild und nur einer Variable versucht um auszuschließen dass es Projekt liegt->gleiches Ergebnis. Wenn ich die selben Variablen auf einer Steuerung mit der Version 2.3.9 SP3 anlege, kann ich sie problemlos lesen (SP4+5 hatten wir nie im Einsatz). Kann es eventuell an den dll files liegen (ARTIClient und symARTIClient) bzw wo finde ich aktuelle Versionen? Arbeite im Moment mit folgenden Versionen:
    ARTIClient.dll Ver.: 2.5.3.2
    symARTIClient.dll Ver.: 2.5.3.1

    Grüße
    Johannes

  5. #5
    Join Date
    30.05.2007
    Posts
    105

    Default Re: 3S Arti NG Treiber - Kommunikationsproblem

    Hallo,

    leider werden die Dateien ARTIClient.dll Ver.: 2.5.3.2 und
    symARTIClient.dll Ver.: 2.5.3.1 von 3S nicht mehr gewartet.
    Generell gibt es nun die Empfehlung die Kommunikation über den PLC Handler laufen zu lassen.
    Daher haben wir nun die Möglichkeit geschaffen in unserem 3S_V3 Treiber auch Verbindungen zu Codesys V2.3 Laufzeiten herzustellen. Diese Erweiterung steht ab Version 7.50 zur Verfügung.
    Falls es für 7.20 benötigt wird, bitte mit dem lokalen Support Kontakt aufnehmen.

    Markus

  6. #6
    Join Date
    27.08.2011
    Posts
    88

    Default AW: 3S Arti NG Treiber - Kommunikationsproblem

    Hallo,

    danke für den Hinweis, lade gerade die 7.50 herunter...
    Funktioniert es mit der 7.20 und dem neuen Treiber definitiv nicht, da kann ich ja auch ARTI und V2.3 auswählen!? Konnte bis jetzt aber keine Verbindung aufbauen!

    Johannes

  7. #7
    Join Date
    27.08.2011
    Posts
    88

    Default AW: 3S Arti NG Treiber - Kommunikationsproblem

    Guten Morgen,

    habe nun die 7.50 installiert. Wo muss ich bei den Treibereinstellungen die IP Adresse der Steuerung eingeben? Habe dazu in der Hilfe nichts gefunden...Knotenadresse??? TargetID???

  8. #8
    Join Date
    30.05.2007
    Posts
    105

    Default Re: 3S Arti NG Treiber - Kommunikationsproblem

    Hallo,

    Ganz genau, bei Knotenadresse, (Node Address) wird die IP Adresse eingetragen.

    In den V2.3 PLC Configuration Einstellungen wählen Sie das passende Transportprotokoll, Vermutlich TCP L4 (TCP Level4) und den korrekten Port der Steuerung (Codesys Default 1200)

    LG
    Markus

  9. #9
    Join Date
    27.08.2011
    Posts
    88

    Default AW: 3S Arti NG Treiber - Kommunikationsproblem

    Jetzt läuft es...allerdings gleich wie mit dem ARTI NG Treiber, d.h. es dauert beim RT Start mehrere Minuten (ca. 10) bis ich einen Wert sehe, bis dahin bleibt das Zahlenwert Element leer (nicht offline mit dem roten Punkt...)

  10. #10
    Join Date
    30.05.2007
    Posts
    105

    Default Re: 3S Arti NG Treiber - Kommunikationsproblem

    Hallo,

    Werden im DiagViewer Meldungen ausgegeben zu diesem Treiber?
    Wenn ja welche?

    Wenn Sie zur Kommunikation die Option Gateway wählen, und über das Codesys Gateway (zb. über den Rechner auf dem Codesys installiert ist) zeigt sich dasselbe Verhalten?
    (IP Adresse in Knotenadresse belassen, Gateway Einstellungen je nach wo es installiert ist)

    LG
    Markus

Similar Threads

  1. Performance des 3S ARTI NG Treibers
    By elso in forum Drivers
    Replies: 3
    Last Post: 11th June 2014, 10:23
  2. burpvi-Treiber 7.00 <-> 7.10
    By michab in forum Drivers
    Replies: 2
    Last Post: 23rd October 2013, 13:39
  3. Kommunikationsproblem mit ModBus TCP
    By schroder in forum Drivers
    Replies: 3
    Last Post: 5th August 2013, 16:58
  4. DNP3 Treiber Frage
    By jusufs in forum Drivers
    Replies: 3
    Last Post: 30th April 2013, 09:42
  5. Replies: 3
    Last Post: 11th October 2011, 23:24

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •