Showing results 1 to 3 of 3

Thread: Beckhoff NG Treiber und TwinCat 3 keine Kommunikation

  1. #1
    Join Date
    14.01.2015
    Posts
    2

    Default Beckhoff NG Treiber und TwinCat 3 keine Kommunikation

    Hallo,

    ich arbeite zur Zeit an einem Twincat 3 Projekt welches mit einer Zenon 7.11 Visualisierung ausgestattet werden soll. Nur leider wollen die Beiden trotz der installation auf dem gleichen Rechner nicht mit einander sprechen.

    Laufzeitsystem: Win / 64 BIT
    PLC: TwinCat 3 (V3.1.4016.12) 64 BIT
    AMS Route: 127.0.0.1 Statische Route ohne Remote PC
    HMI: Zenon 7.11 64 BIT
    Treiber: Beckhoff NG -> AMS Net ID: ID lt. Beckhoff Soft PLC Port: 851

    Da TC3 kein tpy file mehr generiert fällt Importieren vom Treiber weg??!!

    Bei der Variablenerstellung im Zenon benenne ich die Variable genau so wie sie in TwinCat heißt. Aber auch bei eingabe des Offsets im Reiter Adressierung kommuniziert nichts. Ebenfalls habe ich schon versucht einen Punkt (.VarName) vor Kennung und/ oder Variablennamen zu setzen. Auch kein Erfolg.

    Von Beckhoff selbst gibt es keinen Support weil sie lt. Hotline nicht für diesen Treiber verantwortlich sind.

    Über Hilfe / Tipps / Ratschläge würde ich mich sehr freuen.

    Vielen Dank

    Matthias

  2. #2
    Join Date
    30.05.2007
    Posts
    105

    Default Re: Beckhoff NG Treiber und TwinCat 3 keine Kommunikation

    Hallo,

    Ein TPY file gibt es sehr wohl noch, oder wieder.
    Das wurde mit 3.1 wieder von Beckhoff eingebaut.
    Es wird wie das .tmc file im Projektordner angelegt.
    Einzig in diesem File ist keine AMS Net ID mehr enthalten. Die muss man somit manuell eintragen.
    Der Standard Runtime Port für TC3 ist 851, kann aber auch individuell vergeben sein.

    Markus

  3. #3
    Join Date
    14.01.2015
    Posts
    2

    Default Re: Beckhoff NG Treiber und TwinCat 3 keine Kommunikation

    Hallo,

    danke für den Tip! war zwar etwas schwer zu finden (weil Häckchen notwendig)aber jetzt kann ich Variablen importieren inkl Offset usw. nur leider bekomm ich immer noch keine Kommunikation via BeckhoffNG hin. Mit dem TC-ADS Treiber klappt es auf anhieb. Liegt es vielleicht an der Auswahl des Kommunikationsweges bei den Beckhoff-NG einstellungen? Momentan ist "Variablenname" angewählt. Ist das vielleicht die Lösung? Vielen Dank

Similar Threads

  1. Replies: 1
    Last Post: 24th September 2013, 20:47
  2. Replies: 1
    Last Post: 10th September 2013, 00:02
  3. Beckhoff TwinCat NG driver -> Red square
    By sdolnyy in forum Drivers
    Replies: 2
    Last Post: 4th March 2013, 09:49
  4. Bug report for <Beckhoff TwinCat NG driver>
    By lephis in forum Drivers
    Replies: 4
    Last Post: 6th March 2012, 10:11
  5. Replies: 5
    Last Post: 16th July 2008, 09:16

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •