Showing results 1 to 4 of 4

Thread: Setting Language for web-clent

  1. #1

    Default Setting Language for web-clent

    Hello, support team.

    Is it possible to set up russian language for web client?

    LANGUAGE=RUSSIAN line in [DEFAULT] properties group of zenon6.ini, which is working for non-web clients or servers, doesn't work for web client.
    Regards,
    Andrey

  2. #2
    Join Date
    08.10.2007
    Posts
    35

    Default Re: Setting Language for web-clent

    Hello,
    which zenon version do you use?
    Do you get an error message?

    The language file, in this case I think it is called RRUSSI32.dll, seems to be missed.
    This needs to be installed in the RT Installation path as far as I know.

  3. #3

    Default Re: Setting Language for web-clent

    Hello, compu2000

    I use 7.10 version. No error messages, just english interface no matter what settings are in zenon6.ini.
    Where RRUSSI32.dll should be located for web-client?
    I have it only in non-web runtime or editor folders which do not present on pc with web client installed.
    Regards,
    Andrey

  4. #4

    Default Re: Setting Language for web-clent

    Quote Originally Posted by compu2000 View Post

    The language file, in this case I think it is called RRUSSI32.dll, seems to be missed.
    This needs to be installed in the RT Installation path as far as I know.
    It is a bit tricky as the way where the ressources are located changed with zenon 7.11.

    <=7.10:
    A seperate Webclient Setup for each language exists.
    This setup installs the "npzenWebCli.dll" for the choosen language into the zenon webclient installation directory.
    Default Installation path:C:\ProgramFiles(x86)\COPA-DATA\zenon Web Client 7.10
    The "npzenWebCli.dll" contains also the ressource Information about the language.

    =>7.11:
    There is only one Webclient Setup now!
    During the Setup the language to be installed must be choosen.
    The Setup now installs the "npzenWebCli.dll" and in addition the ressource file of the language e.g. RRUSSI32.dll.

    In your case with zenon 7.10 the INI entry has no effect and I suppose you have an englisch webclient installed.
    You need to run the russian zenon Webclient Setup.
    The INI entry works only from zenon 7.11 on.

Similar Threads

  1. Setting transient values to 0
    By knubla in forum zenon Energy Edition
    Replies: 8
    Last Post: 26th May 2014, 10:04
  2. zenon Web-Client 7 -> Web-Server 6.22 slow startup
    By kicker in forum Webserver/Webclient
    Replies: 1
    Last Post: 24th September 2013, 21:11
  3. About Webserver setting
    By sidramsatyal in forum zenon Supervisor
    Replies: 3
    Last Post: 18th September 2013, 11:58
  4. Setting for Restoring PLC Value.
    By navaneet in forum zenon Supervisor
    Replies: 5
    Last Post: 9th September 2013, 00:09
  5. Variable setting
    By whitetaru in forum Drivers
    Replies: 2
    Last Post: 27th April 2011, 01:15

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •