Page 1 of 2 1 2 LastLast
Showing results 1 to 10 of 14

Thread: Colour and infrared sensors

  1. #1
    petzi91 Gast

    Unglücklich Colour and infrared sensors

    Hello community,
    I have the problem that I can`t use the colour AND the infrared sensor together. I have written one program in which I wanted to use both. If I use only one of them (the colour sensor OR the infrared sensor), I will have no problems. But if use both, the colour sensor blinks red instead of shine "colourful" ( because I set Port_1_Mode := 2; so that I can differentiate between different colours).
    Has anybody the same problem or an idea how to solve this problem?
    Kind regards
    Petzi

  2. #2
    patrick0707 Gast

    Default Re: Colour and infrared sensors

    Hello petzi91,

    I have no information that this is not possible.

    have you defined 2 Ports, in your program?

    Best regards,
    Patrick Adlgasser
    Last edited by patrick0707 : 1st August 2014 at 08:02

  3. #3
    petzi91 Gast

    Default Re: Colour and infrared sensors

    Hello Patrick 0707,
    of course, Port 0 is used by the infrarad sensor and port 2 is used by the colour sensor. I tried so much but I don`t know what to do now.
    Best regards
    Petzi

  4. #4
    patrick0707 Gast

    Default Re: Colour and infrared sensors

    And when you use Port 1 for the infrared sensor and port 2 for the colour sensor.

    Best regards
    Patrick Adlgasser

  5. #5
    patrick0707 Gast

    Default Re: Colour and infrared sensors

    When you want you can send your project to our support email address.

    support@copadata.com

    Best regards
    Patrick Adlgasser
    Last edited by admin : 1st August 2014 at 10:16

  6. #6
    petzi91 Gast

    Default AW: Re: Colour and infrared sensors

    Hello Patrick 0707,
    I already tried it, unfortunately it does not make a difference.
    Best regards
    Petzi

  7. #7
    Join Date
    09.08.2014
    Posts
    8

    Cool Re: Colour and infrared sensors

    Hi,
    we have the same problem. We can't use infrared sensor with color sensor together. If we connect only infrared sensor it works fine. If we connect only color sensor it does not works fine. Obviously there is some problem with color sensor but if we test it with embedded Lego software on EV3 it works fine.

  8. #8
    petzi91 Gast

    Default Re: Colour and infrared sensors

    Could you please describe what exactly happens when you only connect the Color sensor? Does it shine red or does it blink?

  9. #9
    Join Date
    09.08.2014
    Posts
    8

    Default Re: Colour and infrared sensors

    In Mode 0 it shines red, in Mode 1 it shines blue, in Mode 2 it shines blue&green

  10. #10
    petzi91 Gast

    Default AW: Re: Colour and infrared sensors

    Okay, I think that this is a good sign. Could you then please describe which problems you exactly have with the colour sensor?

Similar Threads

  1. changing object colour from multiply variables
    By mattsd in forum zenon Supervisor
    Replies: 4
    Last Post: 12th November 2007, 02:09

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •