Showing results 1 to 5 of 5

Thread: Ultraschallsensor und Motoren

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    08.07.2014
    Posts
    5

    Default Ultraschallsensor und Motoren

    hallo,
    I have a question with the Ultrasonic sensor. Ive downloaded all the firmware and software successfully. and my Lego Brick is connected with zenon-straton.

    But there is some problem with the Control part. I have inserted a LEGO EV3 in Feldbusconfiguration. and i added a touch sensor and an ultrasonnic sensor and insert the Variable automatically. Then i clicked online to connect the device. and it succeed. Now i think i can see the change the Varible.

    I druck on the touchsensor, the Value turns from 0 to 1, and the status is 0.
    However,the Ultrasonic sensor keep at 0. and status is 1.
    (there is 2 Ultraschallsensor in the list, that i can choose from. ive tried both of them)

    Could you pls help me about how to control this ultrasonic sensor.
    and by the way, i dont understand how can i control motor in the Lego EV3. in 2012 there is a choice for Motor in NXT, but in EV3 there is only Button and Sensor.

    Thank you for your help
    best regards
    Zimou

  2. #2
    Join Date
    04.11.2013
    Posts
    11

    Default AW: Ultraschallsensor und Motoren

    Hi Zimou,

    I don’t have any information about the sensor yet, but I will try to get some.


    How to control the motor:

    If you want to control the motor, you have to create a Program in zenon Logic. Right-click on the folder “Programs” and chose “Insert New Program…”. A dialog will open and there you can chose the Programming language you want to use. I used “Function Block Diagram”.

    On the right side is a list of function blocks. There you need the “EV3-Foler”.
    In the list all function blocks are listed.
    If you want to start a motor you could use e.g. “EV3ROTATE”, just drag and drop it in the white space.

    You can find a description of all function blocks in this tutorial:
    http://www.zenon-challenge.com/news/...arted.html#top

    After you inserted the function blocks you need to create some variables.
    If you move the mouse over the block a tooltip appears where it is listed which data type is needed for each variable.

    When you are finished with creating the variables just drag and drop them on the right place of the function block (the gray fields).

    Now download the program on the LEGO Mindstorm, change the value of the speed variable and the motor should run.

    Best regards,
    David Schwarzl
    Attached Thumbnails Attached Thumbnails Mindstorm_Motor.PNG  

  3. #3
    Join Date
    08.07.2014
    Posts
    5

    Default Re: AW: Ultraschallsensor und Motoren

    Hi David,

    Thank you very much! My Motor runs successfully with your help. Thats really helpful.

    Thanks again!
    Best regards,
    Zimou

  4. #4
    Join Date
    18.08.2011
    Posts
    6

    Default Re: Ultraschallsensor und Motoren

    But if you insert the fub EV*ROTATE as you describe, then you have to connect the function with an instance of the drive - and the drive is missing in fieldbus configuration!?????

  5. #5
    Join Date
    18.08.2011
    Posts
    6

    Default Re: Ultraschallsensor und Motoren

    ok - i made it!

Similar Threads

  1. Kieback und Peter anbinden
    By senti in forum Drivers
    Replies: 4
    Last Post: 4th September 2018, 14:09
  2. Datenaustausch zwischen V6.50 und V7.00
    By drehpet in forum zenon Network
    Replies: 1
    Last Post: 6th March 2013, 00:53
  3. Name und Ort vom Commandbutton
    By freak80 in forum VBA
    Replies: 3
    Last Post: 2nd March 2011, 01:49
  4. Betriebsstunden und Schaltspielzähler
    By s.koeppe in forum Drivers
    Replies: 2
    Last Post: 9th August 2010, 14:43

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •