Showing results 1 to 3 of 3

Thread: Download Logic prj to EV3

  1. #1
    hansvanzijp Gast

    Default Download Logic prj to EV3

    Hello,

    I followed the steps in the zenonChallenge2014_LEGO_EV3_Tutorial and
    tried to download a simple program to the EV3.

    During download I get a lot of error messages:

    2014/07/03-20:58:06 LoadCode:C:\ProgramData\COPA-DATA\SQL2012\ee569a52-50bb-4426-ae69-6b2645c4869e\FILES\straton\P1\appli.XTI
    2014/07/03-20:58:07 Cycle time overflow
    2014/07/03-20:58:07 ## Status = Unknown
    2014/07/03-20:58:07 Cycle time overflow
    2014/07/03-20:58:07 Embedded software missing: T5BusExZenOnRT
    2014/07/03-20:58:07 ## Status = Error
    2014/07/03-20:58:07 ## Status = Error
    2014/07/03-20:58:07 Cycle time overflow

    I assume the "Embedded software missing" is the critical one.
    It looks I can download the application, but the error's prevent starting it.

    Mindstorms firmware is 1.06H

    What's wrong?

    Hans van Zijp.

  2. #2
    Join Date
    30.05.2007
    Posts
    105

    Default Re: Download Logic prj to EV3

    Hello Hans,

    it seems you have the 'logic to SCADA' fieldbus driver in your project.

    Just remove this driver from the fieldbus configuration setting in your project.

    The logic to SCADA driver is only for use on a PC together with zenon, technical it is working with a shared memory.

    On the LEGO EV3 you have only straton.

    Let us know if it worked then.

    Markus

  3. #3
    hansvanzijp Gast

    Default Re: Download Logic prj to EV3

    Hello Markus,

    Thanks, that fixed it.
    I also had to set the cycle time to 50 msec to get rid of the time out messages.
    Basically I have it running, only the communication between the zenon runtime and the robot is very poor. Zenon gets offline very often. In the diagviewer I get messages like this:
    Project 'P1': Reading variable 'Main/Fwd', array index '0' failed. (All failed) return code '-4'

    Downloading the project from the zenon logic workbench works fine, and also the connection with the Lego application runs well by Wifi, so I think the Wifi connection is not the problem.

    Are there settings to improve this?

    Kind Regards,
    Hans van Zijp.

Similar Threads

  1. Zenon logic
    By sidramsatyal in forum straton / zenon Logic
    Replies: 0
    Last Post: 1st July 2014, 09:45
  2. IEC61850 Commands through Zenon Logic
    By knubla in forum Drivers
    Replies: 4
    Last Post: 16th May 2014, 12:12
  3. Zenon Logic Redundancy
    By davide.galigani in forum straton / zenon Logic
    Replies: 3
    Last Post: 24th April 2013, 07:22
  4. Edit .PRJ files
    By thandong007 in forum zenon Supervisor
    Replies: 6
    Last Post: 16th January 2012, 04:06
  5. ZENON *.prj files extension
    By markuska in forum zenon Supervisor
    Replies: 2
    Last Post: 18th June 2010, 11:07

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •