Showing results 1 to 8 of 8

Thread: webclient 7.0 Umzug von XP nach Win7 scheitert

  1. #1
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default webclient 7.0 Umzug von XP nach Win7 scheitert

    Hallo zusammen,

    woran kann es liegen, dass bei einem Rechner mit Windows7 und Internet Explorer 10 der webclient (von zenon 7.0, webclient build 10) beim Aufruf behauptet, er habe einen Internet Explorer 5 vor sich, und der sei nicht kompatibel?

    Mit firefox lässt sich zwar die Verbindung zum Server herstellen, aber das Bild hat einen weißen Rahmen sowie einen scrollbalken IM Browser-Fenster.

    Sämtliche .ini-, .js- und .htm-Dateien, die mir eingefallen sind, wurden 1:1 vom Vorgänger-Rechner (mit WinXP) übernommen, dort funktionierte alles reibungslos.

    Woran kann das liegen?

    Grüße,
    Michael
    Attached Thumbnails Attached Thumbnails 20140210_webclient_IE_fehler.PNG   20140210_IE_versionsanzeige.PNG  
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  2. #2
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default AW: webclient 7.0 Umzug von XP nach Win7 scheitert

    Update: mit Firefox im Kiosk-Modus hab ich eine zumindest vorrübergehend praktikable Lösung: es bleiben nur zwei Scrollbars übrig, die wiederum unabhängig davon sind, was ich in der initcode.js für %-Werte bei width und height eintrage. Ich bekomme in keinem Fall die echten 100% sichtbar, und wenn ich unter 100% eintrage, wandern die scrollbalken mit...
    Unabhängig davon irritiert mich im Moment noch, dass der Dienst zenAdminSrv nicht automatisch startet, sondern zuerst händisch gestartet werden muss, bevor man die init.htm aufruft. Dieses Verhalten hatte ich bis jetzt noch nie...
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  3. #3
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default AW: webclient 7.0 Umzug von XP nach Win7 scheitert

    Update 2: inzwischen startet - ohne, dass ich etwas geändert hätte - der zenAdminSrv automatisch. Also so, wie man es erwartet. Rechner hochfahren, Benutzer anmelden, dank Autostart das Projekt im webclient starten, fertig. Aber wie gesagt: eine "gescheite" Darstellung klappt nur im Kiosk-Modus und nur mit firefox. IE10 wird hartnäckig als IE5 erkannt und folglich geblockt.

    Ach so, noch was: auf einem XP-Notebook, das während der Umrüstzeit des PC als Ersatz-Bedienplatz eingesetzt wurde, ist das Verhalten im firefox dasselbe: ohne kiosk-plugin bekommt man kein Vollbild, stattdessen einen weißen Rahmen oben und rechts mit integriertem Scrollbar, aber dort wird zumindest der IE (es ist dort glaube ich Version 9 oder 8) erkannt und genutzt - und bei diesem wiederum hat man auch ohne Kiosk-Modus die volle Bildgröße zur Verfügung. Also alles irgendwie ein bisschen wirr...
    Last edited by michab : 12th February 2014 at 14:01
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  4. #4
    martins Gast

    Default Re: webclient 7.0 Umzug von XP nach Win7 scheitert

    hi,

    klingt für mich als würde die BrowserCheck.js da eine Fehlerkennung liefern.

    Was du probiern könntest, ist in der BrowserCheck.js (auf dem Webserver, im Verzeichnis wwwroot/config/) diesen Code hier reinzupasten

    (vorher bitte ein Backup der existierenden BrowserCheck.js machen

    HTML Code:
    function browsercheck(){
    	var UserAgent = navigator.userAgent;
    	var fWin32 = (UserAgent.lastIndexOf('Win') != -1) &&  (UserAgent.lastIndexOf('Windows 3.1') == -1) && (UserAgent.lastIndexOf('Win16') == -1);
    	var fMSIE = (UserAgent.lastIndexOf('Trident') != -1); // search for rendering engine
    	var fNPAPI = (UserAgent.lastIndexOf('Firefox/') != -1) || (UserAgent.lastIndexOf('Chrome/') != -1) || ((UserAgent.lastIndexOf('Safari') != -1) && (UserAgent.lastIndexOf('Version/') != -1));
    	
    	if(fWin32)
    	{
    		//Win32-Browser
    		if(fMSIE)
    		{
    			//Internet Explorer --> use ActiveX-Control
    			return "IEXPLORER";
    		}
    		if(fNPAPI)
    		{
    			//Firefox, Chrome or Safari --> use NPAPI-Plugin
    			return "NPAPI";
    		}
    	}
    	//Non-Win32-Browser or not supported Browser (Opera, ...)
    	return "UNSUPPORTED_BROWSER";
    }
    Vielleicht hilft das ja mal weiter.
    Liebe Grüße,
    Martin

  5. #5
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Default AW: webclient 7.0 Umzug von XP nach Win7 scheitert

    Hallo Martin,

    vielen Dank für den Tipp. Hat nur leider nichts gebracht - wobei sich merkwürdigerweise das Verhalten grundlegend geändert hat, unabhängig von der verwendeten Version von browsercheck.js: im Moment führen Startversuche sowohl bei firefox als auch beim Internet Explorer zu Abstürzen des zenon plugin. :-( Laufen soll das Ganze auf vier webclients, lauffähig ist es derzeit auf einem (dort mit firefox) - Mein Problem bei der Geschichte: ich kann keinen Unterschied zwischen den Rechnern erkennen!

    Viele Grüße

    Michael
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  6. #6

    Default Re: webclient 7.0 Umzug von XP nach Win7 scheitert

    Hallo Michael,

    Soll im Webclient VBA bzw. VSTA verwendet werden?
    Ist das nicht der Fall, könnte sonst noch versucht werden VBA und VSTA in der zenon6.ini zu deaktivieren.

    Wenn man ein Webclient der Version 7.11 verwendet, funktioniert es dann schon?

    Mfg
    Mark

  7. #7
    Join Date
    02.06.2010
    Location
    Freiburg
    Posts
    175

    Daumen hoch mit webclient 7.11 gelingt der Umzug

    Hallo Mark,

    der webclient der Version 7.11 bringt in der Tat Abhilfe! Mit diesem habe ich nach langem Hin und Her jetzt tatsächlich vier funktionsfähige Webclients! Die Erleichterung darüber ist recht groß!
    Zumal ich jetzt auch Hoffnung habe, die zukünftigen Webclients, die schon in der Pipeline warten, realisiert zu bekommen.

    Viele Grüße

    Michael
    zenOn Supervisor 7.60 + webserver pro

    Windows Server 2008 R2 / Windows 7 Enterprise

    ModbusTCP / LON / OPC / SQL / B&R

  8. #8
    Join Date
    26.07.2011
    Posts
    123

    Default AW: webclient 7.0 Umzug von XP nach Win7 scheitert

    Hallo Zusammen,

    ich habe auf einer Windows 7 Maschiene den gleichen Fehler im IE10 bekommen.
    Bei mir wurde der Webclient aber nach Einfügen von Martins HTML Code in die browsercheck.js wieder problemlos ausgeführt.
    Danke für den aktualisierten Browsercheck.

    Gruß Tobi
    Zenon 8.00

    Zenon Server Windows R2016

    Clients WebClientStarter / Windows 10 Enterprise

    ZenonWebserver 8.00



    --trust me i'm an engineer--

Similar Threads

  1. Umzug Zenon Runtime und Archive auf anderen Server
    By zero in forum zenon Supervisor
    Replies: 2
    Last Post: 29th January 2014, 10:47
  2. ARX Formatunterschiede in Win7 / WinXP ?
    By wrs402 in forum zenon Supervisor
    Replies: 4
    Last Post: 29th August 2012, 01:31
  3. Probleme mit WebClient und IE 9 / WIN7
    By kfn3000 in forum zenon Network
    Replies: 5
    Last Post: 23rd July 2012, 07:42
  4. Projekt von Zenon 6.20 SP4 Build5 nach 6.22 SP1 Build0
    By xxx in forum Editor and Runtime Setup
    Replies: 1
    Last Post: 2nd June 2009, 10:33

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •