Showing results 1 to 2 of 2

Thread: Problem mit Verbindung zwischen Zenon 7.10 und PC mit Beckhoff zwecks VISU-Simulation

  1. #1
    Join Date
    09.09.2013
    Posts
    26

    Default Problem mit Verbindung zwischen Zenon 7.10 und PC mit Beckhoff zwecks VISU-Simulation

    Hallo an Alle,

    leider habe ich ein grundsätzlichen Problem mit der Verbindung zwischen zwei PC's, damit das Zusammenspielen (Kommunikation) zwischen VISU (Zenon V7.10) und SPS (Beckhoff) getestet werden kann.

    Verfüge zurzeit über Zenon-Demoversion mit installierten TC-ADS-Treiber (auch BeckhNG, usw.) vom Beckhoff auf einem Rechner, auf dem anderen Rechner ist Beckhoff-TwinCAT-Software installiert, sodaß Simuliert werden kann.

    Wir sind inzwischen soweit gegangen, um möglichst viele Fehlerquellen zu minimieren, daß wir beide Rechner zusammen per EthernetIP (peer-to-peer) verbunden und Firewall komplett ausgeschaltet haben.

    Ferner haben wir bei Zenon mit IP-Server-Adresse gespielt und entsprechend den Einstellungen unter TwinCAT-Umgebung die NetID-IP-Adressen verstellt, sowohl bei Zenon unter den Treiber-Einstellungen wie auch unter TwinCAT-Umgebung (Protokolle EtherCAT, EthernetIP).

    Leider beim Versuch, Variablen aus der Steuerung mittels Treiber auszulesen, bekommen wir diese nicht zu sehen, sodaß wir diese auch nicht übernehmen können.

    Die Verbindung, ping'en erfolgt erfolgreich.

    Es würde mich freuen, wenn jemand die Schritte aufzeigen könnte, wo was eingestellt werden muß, um die Verbindung zwischen laufender TwinCAT-Simulation und Zenon zu bekommen.

    Danke im Voraus und Gruß,
    Luc.

  2. #2

    Default Re: Problem mit Verbindung zwischen Zenon 7.10 und PC mit Beckhoff zwecks VISU-Simulation

    Hallo Luc,

    Im Prinzip ist es recht einfach, aber manchmal versteckt sich doch die eine oder andere Fehlerquelle im Detail


    1) am PC mit zenon Editor, TwinCAT CP installieren (aus dem TwinCAT Setup), Rechner neu starten.

    2) am PC mit zenon Editor, TCADS Communication Library installieren (zB: von der zenon DVD) -> die TwinCAT Treiber verwenden die TcADSDll.dll für die Kommunikation

    3) am PC mit zenon Editor, über den TwinCAT System Manager (blaues Icon in statusbar), den AMS Router konfigurieren. -> Ein Route hinzufügen zu dem Rechner mit der TwinCAT SPS. Über "broadcast search" sollte die TwinCAT SPS am anderen Rechner gefunden werden

    4) am PC mit der TwinCAT SPS, im AMS Router prüfen ob die Route zum Rechner mit dem zenon Editor existiert

    5) am PC mit der TwinCAT SPS, das TwinCAT Projekt so konfigurieren, dass Symbole verwendet werden, und in die SPS geladen werden.

    5) am PC mit der TwinCAT SPS, mittels TwinCAT PLC Control, das SPS Programm laden, und starten. -> Ggbf. prüfen ob die Portnummer die Standard Portnummer ist (801), und auch die Firewall eine Ausnahme konfiguriert hat. Im Ausgabefenster soll ersichtlich sein, dass auch die Symbole geladen werden.

    6) am PC mit dem zenon Editor, in der Treiberkonfiguration, die AMS Net ID und Portnummber eintragen, und die Variablen sollte man online importieren können (wenn der Beckhoff TCADS Treiber verwendet wird). -> Es ist allerdings zu empfehlen, den modernen BeckhoffNG Treiber zu verwenden, der unterstützt allerdings nicht den Online Import.

    Ich hoffe, das hilft schon mal etwas weiter


    Mfg
    Mark

Similar Threads

  1. Replies: 1
    Last Post: 22nd May 2013, 00:33
  2. Problem mit Auflösung in Zenon 7
    By sniggi in forum zenon Supervisor
    Replies: 3
    Last Post: 31st July 2012, 14:51
  3. Problem mit SE Treiber unter zenon 6.xx
    By markusw in forum Drivers
    Replies: 2
    Last Post: 21st April 2009, 15:05
  4. Problem mit zenOn und Outpost Firewall Pro
    By hp in forum zenon Network
    Replies: 1
    Last Post: 16th October 2008, 15:52
  5. Replies: 5
    Last Post: 16th July 2008, 09:16

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •