Showing results 1 to 2 of 2

Thread: Scripting On client not running

  1. #1
    Join Date
    17.04.2013
    Posts
    1

    Default Scripting On client not running

    I have a script that need to run on every client and uses internal local variables but must be triggered from an outside source/tag. I have tried running a function from a limit or even a reaction matrix but it only runs on the main server and not on any of the clients. Any ideas would be helpful, Thanks. Oh its zenon 7.0

  2. #2

    Default Re: Scripting On client not running

    Hi bigred44,

    Thanks for your post and welcome to the forum

    When you select the function you have linked at the limit and look at the properties, you can select where the function is executed. By default this would be "current PC". In case of a global limit violation this means the function is executed on the server. (as the server processes the limits)

    When you tick the box to also execute the function on the clients, this may be what you are after.

    Best regards,
    mark

Similar Threads

  1. Zenon 7 registration error with "ZenDbSrv is running" message
    By stolyarov_as in forum zenon Supervisor
    Replies: 5
    Last Post: 7th June 2013, 11:47
  2. Email message while running converted to zenon7 project
    By stolyarov_as in forum zenon Supervisor
    Replies: 6
    Last Post: 18th October 2012, 15:05
  3. A code which is running everytime
    By kinoxy in forum VSTA
    Replies: 2
    Last Post: 24th March 2011, 21:01
  4. Getting started with scripting
    By rouxc in forum VSTA
    Replies: 2
    Last Post: 23rd September 2010, 23:49
  5. Runtime from SICAM230 not running
    By alexovy in forum zenon Energy Edition
    Replies: 2
    Last Post: 25th February 2010, 00:44

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •