Hallo.

Wir haben ein massives Problem mit dem Update auf Zenon 7.10.
Der Support ist schon eingeschaltet, aber vielleicht hat ja jemand anderes ähnliche Erfahrungen gemacht und ggfs. Lösungen parat.

Wir haben ein Zenon 6.51 Integrationsprojekt (mit globalem Dachprojekt) mit dem Zenon 7.10-Editor importiert und die Fragen nach dem Konvertieren auf Version 7.10 mit "Ja" beantwortet.
Alle Server heruntergefahren und die neue Zenon-Version installiert, anschliessend die Runtime-Ordner gelöscht und alle Projekte auf dem Entwicklungsrechner mit 7.10 (RT erzeugen für auf "Default" + alle Häkchen bei Auswahl der zu erzeugenden Dateien herausgenommen) kompiliert und übertragen.
Nun die Runtime auf den Masterservern gestartet (nacheinander - einer managed das Integrationsprojekt, der andere die ganzen Projekte).

Nun fängt der Server an zu starten, sucht die ganzen anderen Standbyserver und bringt irgendwann die Fehlermeldung:

"Fehler: Die Datei 'templates.cmp' hat die Versionsnummer 7.10 SP0 - das Projekt hat aber die Versionsnummer 7.00 SP0"

Es werden eine Reihe von .cmp Dateien bemängelt (alc, msgctrl etc.) aber auch .ZPP- Dateien.
Alle Versuche diesem Fehler Herr zu werden, schlugen fehl.
Wir haben derzeit nur eine funktionierende, aber nicht gewünschte Methode gefunden:
Die ganzen Dateien als 7.00-Dateien zu komilieren und das ganze dann unter 7.10 zu starten.

Nun das Fatale: Ein Wechsel zurück auf 6.51 ist nicht mehr möglich !!!!!
Egal mit welcher Editorversion und Runtimeversion - der Abbruch mit Versionshinweis kommt jedes Mal.

Wenn man in die Project.ini- Dateien schaut, so steht dort unter Version 1 + 2 jeweils die richtige Version drinnen.

Jörg Ammermann