Showing results 1 to 6 of 6

Thread: X-Axis configuration in Report Builder

  1. #1
    Join Date
    29.07.2007
    Location
    Linz
    Posts
    50

    Default X-Axis configuration in Report Builder

    Hi,
    I have to generate a report of a welding process.
    Therefore I use ZenOn 7 with Report Viewer.
    The parameters, I am interested in, will be stored within archive server.

    Now, I use Report Builder to create and configure the chart. The chart should display the value of the archive variable as y-value and a relative timestamp as x-value. Displaying the graph works well, but I have troubles to configure the x-Axis.

    The axis should start with zero and ends with "Timestamp of last entry in archiv" minus "timestamp of first entry in archive". (the duration of the welding process should be the max. value of x-Axis)

    Any ideas how to configure the axis to achieve that?

    Thanks.

    Regards,
    Alex

  2. #2
    Join Date
    29.07.2007
    Location
    Linz
    Posts
    50

    Default AW: X-Axis configuration in Report Builder

    any ideas?

    is it possible to store a relative timestamp in the archive server? (begin with 0 at archive start and increase time while archive server is running)

    regards,
    alex

  3. #3
    Join Date
    25.06.2012
    Posts
    155

    Default Re: X-Axis configuration in Report Builder

    Hello gralex,

    Yes. To do it in Microsoft Report Builder you need to define the x-axis source as an expression and not only the archive timestamp

    Follow attached pictures:

    1. Capture1.jpg: Right-click on timestamp and select Category Group properties
    2. Capture2.jpg: Add function.
    3. Capture3.jpg: Set expression.

    And save report.

    4. Capture4.jpg: Runtime look.

    I also attached a project backup to you check these configurations.

    Let me know if this worked fine for you and/or if you have any questions.

    Of course, this is a sample project and it must be adapted to fit exactly your project specification. Please remember this is only intended for demonstration.

    Best regards,
    DC
    Attached Thumbnails Attached Thumbnails capture1.jpg   Capture2.jpg   Capture3.jpg   Capture4.JPG  
    Attached Files Attached Files

  4. #4
    Join Date
    29.07.2007
    Location
    Linz
    Posts
    50

    Default AW: X-Axis configuration in Report Builder

    Hi,

    thanks for your hint!
    This was my aproach too. But if I set the axis properties (interval and interval-type) it doesn' t work anymore.
    The x-axis should be scaled in 10 second steps. How can I get this?

    Regards,
    Alex
    Attached Thumbnails Attached Thumbnails axis-props.PNG  

  5. #5
    Join Date
    29.07.2007
    Location
    Linz
    Posts
    50

    Default AW: X-Axis configuration in Report Builder

    I didn' t solve it right now.
    please help.

  6. #6
    Join Date
    25.06.2012
    Posts
    155

    Default Re: X-Axis configuration in Report Builder

    Dear all,

    I've implemented a solution to show a time range of 0-300 seconds with 100 seconds set as time interval. In the runtime:



    The core of the configuration in the report definition file (Report.rdl) is the following:


    For the 100 seconds time interval set in the graph within 0-300 seconds range, see the properties below in the report:



    You can find the project backup (v8.00) sample attached for educational purposes.

    Best regards,
    David Cerdeira
    Attached Thumbnails Attached Thumbnails 2019-06-19_13h09_43.png   2019-06-19_13h25_43.png   2019-06-19_13h27_34.png  
    Attached Files Attached Files

Similar Threads

  1. OPC Client configuration
    By luca.bardon in forum Drivers
    Replies: 12
    Last Post: 17th October 2012, 10:08
  2. facePlate configuration
    By ansab.tp in forum zenon Supervisor
    Replies: 3
    Last Post: 25th January 2012, 00:47
  3. Time axis in the pdf print
    By hamid in forum zenon Supervisor
    Replies: 4
    Last Post: 26th September 2011, 09:42
  4. Replies: 9
    Last Post: 20th April 2011, 18:30
  5. SNMP-Configuration
    By rolindo in forum zenon Network
    Replies: 4
    Last Post: 11th December 2009, 08:36

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •