Showing results 1 to 10 of 14

Thread: ZenonRT hangs

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Ausrufezeichen ZenonRT hangs

    Good day.

    Periodically ZenonRt hangs and I get error message:

    Description:
    A problem caused this program to stop interacting with Windows.

    Problem signature:
    Problem Event Name: AppHangB1
    Application Name: Zenrt32.exe
    Application Version: 7.0.10450.0
    Application Timestamp: 4f6c3dc7
    Hang Signature: 7574
    Hang Type: 6400
    OS Version: 6.1.7601.2.1.0.256.48
    Locale ID: 1049
    Additional Hang Signature 1: 7574db150657404d20584318a3cac69f
    Additional Hang Signature 2: c60c
    Additional Hang Signature 3: c60c19a590ac7922cbbacfdd5648f4f1
    Additional Hang Signature 4: 7574
    Additional Hang Signature 5: 7574db150657404d20584318a3cac69f
    Additional Hang Signature 6: c60c
    Additional Hang Signature 7: c60c19a590ac7922cbbacfdd5648f4f1

    What should I check to solve this problem?

  2. #2

    Default Re: ZenonRT hangs

    Hi Croc,

    Of course the zenon runtime should not hang, and this normally also does not happen. However zenon is an open and very flexible product, and there can be scenarios where as a zenon engineer you create something that is not ideal.

    I assume this happens with a specific project, under specific circumstances. Best thing to do, is check with your local COPA-DATA support and let them help you figure out what may be causing this

    It helps if you can provide them with a test project and an instruction of how this can be reproduced!

    Best regards,
    Mark

  3. #3

    Default Re: ZenonRT hangs

    Hi, Mark and everybody who read this forum.

    I have checked local COPA-DATA. They recommended to install new Zenon 7 SP0 Ver02. I have Zenon 7.00 SP0 now. How do you think, Mark, it will really help to solve the problem with the hang?

    I wouldn`t like to wasting my time. I would like to understand what happens with my project. I`ve done some screens while Zenon was hanging: 1 - with diagnosis viewer, 2 - with resource monitor. Please see the attachment. May be this will help to understand what is the reason of hang.

    May be something more that I need to do? For any advice will be very appreciated!

    Regards.
    Attached Thumbnails Attached Thumbnails resource_monitor.bmp   diag_viewer.jpg  

  4. #4
    Join Date
    30.05.2007
    Location
    Salzburg
    Posts
    880

    Default AW: ZenonRT hangs

    Check out if you have configured functions which are execute via the module "Time control"
    -> if yes, does the execution intervall fit to the occurence of the mentioned behaviour?

    Otherwise you can also try to deactivate VBA in the zenon6.ini
    [VBA]
    EIN=0

    In the logfile you can see a message "100ms Timer has not cycled for... "
    -> this is an indication the the zenon Runtime is blocked

    regards,
    herbert

  5. #5

    Default Re: AW: ZenonRT hangs

    Quote Originally Posted by herberto View Post
    Check out if you have configured functions which are execute via the module "Time control"
    -> if yes, does the execution intervall fit to the occurence of the mentioned behaviour?

    Otherwise you can also try to deactivate VBA in the zenon6.ini
    [VBA]
    EIN=0

    In the logfile you can see a message "100ms Timer has not cycled for... "
    -> this is an indication the the zenon Runtime is blocked

    regards,
    herbert
    Thank you, Herbert, for your advice.

    I checked the module "Time Control" - there are no functions.
    Also I tried to deactivate VBA in zenon6.ini. It did not give any change.

    I noticed that Runtime hangs when variables (from OPC Client driver) don`t load. May be the reason of hang is the work of OPC-driver?

    What can block zenon Runtime?

  6. #6
    Join Date
    30.05.2007
    Location
    Salzburg
    Posts
    880

    Default AW: ZenonRT hangs

    Which OPC Client do you use?
    OPC UA (OPCUA32.exe)
    OPC DA (OPC2CLI32.exe)

    How are those variables requested?
    -> showing in a screen, ....

    What about the load of the OPC driver?
    -> which cycle time did you configure?
    -> did you activate the checkbox "Keep update list in memory"?
    -> do you have several connections definied within the OCP driver?
    --> if yes, create for each connected PLC a seperate OPC driver

Similar Threads

  1. Zenon Process Gateway Hangs
    By shikra in forum zenon Energy Edition
    Replies: 2
    Last Post: 7th February 2012, 13:54
  2. Runtime hangs
    By shikra in forum zenon Energy Edition
    Replies: 2
    Last Post: 16th May 2010, 23:19
  3. installation of 6.22 SP0 hangs, leaving the system in an inoperable state
    By markclemens in forum Editor and Runtime Setup
    Replies: 0
    Last Post: 10th March 2008, 17:44

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •