Showing results 1 to 2 of 2

Thread: Modbus driver - detecting link or device failure

  1. #1
    Join Date
    05.03.2009
    Posts
    23

    Default Modbus driver - detecting link or device failure

    Hello!

    I have several devices connected via RS485 and Modbus RTU/TCP driver to Zenon EE.
    I would like to detect device failure or link failure. I went through all driver variables, but I could not find appopriate driver variable. Is there a driver variable which holds the information of satus of link or if the device is unresponsive?
    I know that such a driver variable (status of link) is available for for IEC 104 protocol.

    Gregor

  2. #2

    Default Re: Modbus driver - detecting link or device failure

    Hi,

    The modbus RTU driver is a polling driver. This means that every driver update cycle, an attempt is made to read the variables required by the runtime from the RTU. In case this fails, e.g. due to a broken cable, it will continue to attempt to read the variables from this RTU depending on the reconnect timeout.

    Meanwhile, when a connection error has been detected, all variables keept their last known value, but also have the status bit "INVALID" set to TRUE (1)

    This status bit "INVALID" can be monitored with e.g. a reaction matrix, and you can generate an alarm, or execute a function to perform further actions. (popup screen, SMS or e-mail message, ...) You would only need to link this reaction matrix to one variable of each RTU (each link / station), to monitor the connections.

    Unlike the IEC 104 driver, most polling drivers do not have a seperate variable to indicate the link status, and only use the INVALID bit.

Similar Threads

  1. How to use Variable tagname in link text element?
    By softart2 in forum zenon Supervisor
    Replies: 2
    Last Post: 17th June 2010, 08:11
  2. Prot. Relay-Power supply failure monitoring
    By janlyndon in forum zenon Supervisor
    Replies: 10
    Last Post: 18th May 2010, 22:57
  3. How to link zenOn and straton in zenon6.22?
    By nahala in forum straton / zenon Logic
    Replies: 2
    Last Post: 29th March 2009, 11:37
  4. CE Device won't comm. with PLC
    By scotttee in forum zenon Operator
    Replies: 5
    Last Post: 9th March 2009, 14:13
  5. Renaming scripts loses the link at the function
    By markclemens in forum zenon Supervisor
    Replies: 0
    Last Post: 3rd August 2007, 07:23

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •