Page 1 of 2 1 2 LastLast
Showing results 1 to 10 of 11

Thread: Probleme mit dem SMS versenden

  1. #1
    Join Date
    04.01.2010
    Posts
    16

    Default Probleme mit dem SMS versenden

    Hallo,

    nach vielen Problemen mit dem Message Control bin ich nun soweit das ein Eintrag in die msgctrl.txt erfolgt.
    Beim ersten Alarm kommt der Eintrag das die Nachricht in den Ausgang gelegt wurde. Es kommt aber keine SMS an. Die Nummer ist aber die richtige.
    Versuche ich nun eine zweite SMS zu versenden kommt der Eintrag the selected line is busy.
    Leider habe ich so langsam keine Ideen mehr wo das Problem liegen könnte. Mit der Software des GSM Modem (Huawei E1550) lassen sich ohne Probleme SMS versenden.
    Ich würde mich über jegliche Lösungsvorschläge sehr freuen.

    Gruß
    Simon

  2. #2

    Default Re: Probleme mit dem SMS versenden

    Hallo,

    "selected line is busy" hört sich fast so an, als ob paging SMS versand verwendet wurde anstatt GSM SMS versand.

    In Message Control gibt es eben diese beide Versandarten, nicht dass versehentlich paging statt GSM SMS bei der Sende Nachricht funktion verwendet wird.

    Falls GSM SMS verwendet wird, wurde eine spezielle Initialisierungsstring eingestellt beim GSM Modem?

    Eventuell könnte folgender String versucht werden:

    ATQ0 V1 E1 S0=0&C1&D2 +FCLASS=0

    Click image for larger version

Name:	ScreenShot460.png
Views:	30
Size:	13.8 KB
ID:	612

    Zeigt der Konfigurationsdialog im Editor die Signalstärke des GSM Signals und den Provider korrekt an?

    Ist die SMSC Nummer vom Provider die richtige?

    Click image for larger version

Name:	ScreenShot461.png
Views:	21
Size:	16.9 KB
ID:	613

  3. #3
    Join Date
    04.01.2010
    Posts
    16

    Default AW: Probleme mit dem SMS versenden

    Hallo,

    als Versandart ist GSM SMS gewählt.
    Der von ihnen angegebene Initialisierungsstring scheint keine Besserung zu bringen.
    Empfang und Provider werden korrekt dargestellt. Die Nummer des SMSC sollte ebenfalls passen. Zumindest ist es die gleiche Nummer die auch das mitgelieferte Programm nutzt.

  4. #4

    Default Re: Probleme mit dem SMS versenden

    Ich kenne das Huawei E1550 persönlich nicht, allerdings weiss ich, dass damit bereits erfolgreich Nachrichten versendet wurden mit MessageControl.

    Das Huawei E169 was ich hier habe, installiert zwei COM-Ports und ein Modem (mit eigenem COM-Port).

    Ein COM-Port kann im MessageControl eingestellt werden, und liefert auch ein Signal und Providerinfo zurück. (3G PC UI interface) Der andere COM-Port (3G Application interface) liefert keine Informationen.

    Der COM-Port vom Modem (Huawei mobile connect 3G Modem) liefert ebenfalls ein Signal zurück.

    Eventuell gibt es mit dem E1550 auch mehrere Ports, und kann es mit einem anderen COM Port noch versucht werden.

    Sonst hätte ich so keine Idee, und würde in diesem Fall den lokalen Support kontaktieren um das Problem zu lösen.

  5. #5
    Join Date
    04.01.2010
    Posts
    16

    Default AW: Probleme mit dem SMS versenden

    Was mich wundert ist, das wenn ich mit einem extra Programm (Sniffer) die Kommunikation zum Com-Port überwache dort absolut nichts passiert wenn eine SMS versendet werden soll. Gehe ich aber z.B. in die Konfiguration um mir die Empfangsstärke anzuzeigen werden in einer Tour AT-Befehle abgegeben auf die das Modem auch antwortet. Sollte nicht wenn eine SMS raus gehen soll dieses auch als AT-Befehl zu sehen sein?

  6. #6
    Join Date
    29.07.2007
    Posts
    19

    Default Re: Probleme mit dem SMS versenden

    Die Informationen aus der msgctrl.txt dienen als zusätzliche Information zur was wird in der CEL geschrieben wird.
    Die CEL zeigt die wirkliche Information zur Nachrichtensendung mit MC.

    Haben Sie eine CEL-Screen in Ihrem Projekt?

    Wenn nicht legen Sie bitte ein Bild von dem BildTyp „“Chronologische Ereignisliste“ ein.
    Achten Sie dass bei der MC Konfiguration alle Information zur Nachrichten angezeigt werden sollen. (Globale Einstellungen>Alle Bestätigungen)

    Stimmt die SMSC-Nummer?
    Welcher Provider haben Sie?
    Kann dieser in UMTS NETZ SMS versenden?

    Note aus Forum: http://www.copadata.com/forums/showthread.php?t=57
    Note: If the used provider in Message Control requires a UMTS NET, the modem has to be UMTS enable.
    In this case we tested successfuly the USB-modem Huawei E1550

    Wir haben bereits so ein Modem Huawei E1550 im Haus und es funktioniert einwandfrei.

    Bitte versuchen Sie folgendes:

    1. Ziehen Sie das Modem aus dem USB-Port raus.
    2. Stecken Sie diesen in USB-Port wieder ein.
    3. Falls Sie eine Software zur Modem haben, mit welche Sie SMS versenden können, testen Sie dies. Funktioniert diese einwandfrei? (Welche Provider?)
    4. Überprüfen Sie in Systemsteuerung > Modem und Telefon > Modems > welche wird Anschluss genommen? Ist das übereinstimmend mit dem in MC-Konfiguration? Wenn nicht passen Sie diese an.
    5. Stimmt die Standard SMSC?
    6. Stimmt die eigene Nummer?
    7. Speichern
    8. RT-Files erzeugen.
    9. RT starten

    Sendenachrichten Funktion testen.
    Bitte testen Sie mit einen Button ( per Hand ), ist es besser in der CEL zu nach zu vollziehen.

    Was wird in der CEL geschrieben?

  7. #7
    Join Date
    04.01.2010
    Posts
    16

    Default AW: Probleme mit dem SMS versenden

    Erstmal vielen Dank für den umfangreichen Fragenkatalog.

    Die CEL ist vorhanden und auch nach ihren Angaben eingestellt. Ein Eintrag erfolgt aber nicht.

    Mit dem mitgelieferten Programm funktioniert der SMS-Versand einwandfrei. Die Einstellung für das SMSC wurde aus dem Programm übernommen.

    Der Provider ist Vodafone. Das Modem wurde so konfiguriert das es kein UMTS nutzt. Es bucht sich lediglich ins GSM-Netz ein.

    Ansonsten habe ich heute noch mal das MC komplett neu konfiguriert aber ohne Erfolg.

  8. #8
    Join Date
    29.07.2007
    Posts
    19

    Frage Re: Probleme mit dem SMS versenden

    Quote:
    Die CEL ist vorhanden und auch nach ihren Angaben eingestellt. Ein Eintrag erfolgt aber nicht.

    Gar keine Meldung? oder doch eine Meldung, wenn ja welche genau?

    Das einzige was mir bei Ihrer Beschreibung ausfällt ist dass Sie das Modem extra für die GMS Netz konfigurieren. Das machen wir nicht. Es wird so gelassen wie es ist, keine extra Konfiguration.

    Hier unser Vorgehensweise wenn wir das Modem E!555 benutzen:

    • Modem ist bereits installiert und SMS kann mit dem mitgelieferten Programm SMSs gesendet werden.

    • Mitgelieferten Programm schliessen.

    • Modem wird in Systemsteurung noch geprüft.
    COM-Schnittstelle überprüfen.
    Übertragungsrate checken und notieren (Bsp.115200)
    Modem über Button ansprechen.

    • Message Control in zenon
    o MC konfiguration > Globale Eisntellungen > alle Bestätigen
    o Übertragunsmedien > Einstellungen

    Schnittstelle prüfen (evtl hinzufügen)
    Eigenschaften
    Geräteeigenschaften >
    Standard-SMS+49 (Providervorwahl(Vodafone) Zbsp:+49152xxxxxxxx
    Eigene Nummer +49( Nummer von SIMCard für Modem)
    Com-Anschluss > Bits pro sekunde (Übertragungsrate Z Bsp 115200)
    Empfängersignal Ok.

    Dienste prüfen
    (Ist Vodafone in der Liste?
    Ist Vodafone in der Standarddiesnte ausgewählt?

    • Message control > Empfänger
    Telefon: GSm-Provider und GSM-Nummer (+49 z Bsp Ihre Handynummer)

    • In zenon > Sende Funktion erstellen und auf button legen. Idearlerweise schon in dem CEL-Bild.Es ist so leichte nachzuvollziehen ohne ein Bild umschalten zu müssen.

    Nach Anstoßen der Sendeunktion und Einkommen bei Empfänger muss ein Eintrag in die CEL geschrieben werden, dass Nachricht erfolgreich gesendet wurde.
    oder steht in CEL dass Senden fehlgeschlagen oder es steht Nichts in CEL. Es hilft nur noch mal in der gesamten Konfiguration alles wieder zu checken.

    Hier hilft die Datei msgctrl.txt. Was ist der Inhalt der letzten Kommunikation?
    Was wurde dort geschrieben?
    Es beginnt mit: SendMessages: 1 messages exists
    Unter anderen an welche nummer wurde gesendet? Ist es richtig? Provider? usw.
    Es endet mit: GSM-TansInfo: 1-Nachricht an +49152xxxx(empfängenummerI) erfolgreich versandt: 1; Test aus dem MC-

    Ich hoffe das Hilft Ihnen weiter und viel Erfolg beim Testen.

  9. #9
    Join Date
    04.01.2010
    Posts
    16

    Default AW: Probleme mit dem SMS versenden

    Das Modem wurde so konfiguriert, da wir hier ein ganz schwaches UMTS Netz haben und sich das Gerät sonst immer vom einen in das andere Netz umbucht. Ich hatte es aber vorher auch ohne diese Einstellung getestet.
    Ansonsten bin ich eigentlich genau so vorgegangen wie sie es hier beschreiben. Nur habe ich das Phänomen das die Einstellungen aus dem Editor nicht in der Runtime ankommen. Daher konfiguriere ich alles direkt in der Runtime.

  10. #10
    Join Date
    29.07.2007
    Posts
    19

    Default Re: Probleme mit dem SMS versenden

    Was kommt in die CEL, gar nichts oder doch eien Meldung?
    Welche Einstellungen genau werden in RT nicht übernohmen?
    Haben Sie die RT-änderbaredatei für MC in Editor überprüft? (Editor >Allgemein>RT änderbare Daten Kein Hacken bei der Option „Nicht neu erzeugen und übertragen“)

    Sie können evtl die RT-Verzeichnis oder unbennen im Editor und neu erzeugen.

Similar Threads

  1. Replies: 1
    Last Post: 19th January 2010, 23:54
  2. Probleme mit dem Sqldrv
    By matthias.zoellner in forum Drivers
    Replies: 6
    Last Post: 21st January 2009, 11:57
  3. SMS über ISDN versenden
    By sknoerr in forum zenon Network
    Replies: 1
    Last Post: 19th December 2008, 12:39
  4. Replies: 10
    Last Post: 2nd September 2008, 07:54

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •