Showing results 1 to 3 of 3

Thread: Runtime hangs

  1. #1
    Join Date
    04.09.2009
    Posts
    84

    Default Runtime hangs

    Guys, I have been working on Zenon 6.50 SP0 Build1, installed on Windows XP 2002 Service pack 3, and everything was working fine up till now. When I edited an already created Worldview picture and tried to start the Runtime, it simply hanged. The cursor isn't visible in the text elements, I can't click anywhere on any button or menu?

  2. #2
    Join Date
    04.09.2009
    Posts
    84

    Default Re: Runtime hangs

    Problem solved

    A script that was executing 4 functions namely Set focus to Frame, Move focus, Activate Input to the elements with focus and picture switch was modified by deleting the last function 'picture switch'. Everything is working fine now

  3. #3

    Default Re: Runtime hangs

    in this case, the function "activate input on elements with focus" may have called again the picture switch function, wich on it's turn, again set the focus, and activated the input on the element with the focus. A typical example of an endless loop. In the runtime it appears everything hangs. You can recognize this by looking at the taskmanager to the CPU load for the process "zenrt32.exe" If it is at 100% (or 50% on a dual core system) this is an indication for an endless loop.

Similar Threads

  1. Replies: 1
    Last Post: 1st April 2008, 11:58
  2. installation of 6.22 SP0 hangs, leaving the system in an inoperable state
    By markclemens in forum Editor and Runtime Setup
    Replies: 0
    Last Post: 10th March 2008, 17:44
  3. the runtime crashes every time during the runtime start
    By sebastiank in forum zenon Operator
    Replies: 0
    Last Post: 27th August 2007, 10:27

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •