Showing results 1 to 4 of 4

Thread: Default value ACL when no power supplied

  1. #1
    Join Date
    04.12.2020
    Posts
    3

    Default Default value ACL when no power supplied

    Hi,

    Is there a way to change the default black color to Green if no power is supplied to a substation?
    I know you can change the clolor of the lines to Green but it seems to cause an issue with combine elements using ALC.
    If there is no power it defaults to Black if ACL is enabled.

    A seccond issue with a combine ellement is that the whole symbol is colored even when the switch is in the open position.

    I'm using Zenon 10.
    Attached Thumbnails Attached Thumbnails 2022-04-15 14_47_42-zenon Energy Edition.png   2022-04-15 14_50_36-zenon Energy Edition.png  

  2. #2
    Join Date
    01.07.2008
    Location
    Salzburg, AT
    Posts
    1,117

    Default Re: Default value ACL when no power supplied

    hmm, when you write "ACL" do you mean ALC or something else?

    On the screenshot it is not an unsupplied substation, but the broken communication (variables are in INVALID state - red squares at upper right corners). Then for zenon the substation is in UNDEFINED state (not possible to tell if lines are supplied or not). The color for UNDEFINED grid is black, it is #0 entry in the list of ALC sources configuration.

    Just make your combined elements to use graphics drawn using green, not black. And make sure that linked variables are SPONT and have values 0 or 1.

    Are you sure that during the project compilation there are no ALC errors/warnings in the output window?
    Last edited by ursulak : 15th April 2022 at 14:19 Reason: project compilation errors?

  3. #3
    Join Date
    04.12.2020
    Posts
    3

    Default Re: Default value ACL when no power supplied

    It is ALC.
    There is indeed no communication but I'm setting the values manualy at the moment so the Red squares are normal at the moment (Just a test setup) so it is not the "undefiened" state (This is actualy set to Blue for the moment) 
    The problem is that with ALC enabled the symbol wil be drawn in Black if no power is supplied on the line.

  4. #4
    Join Date
    01.07.2008
    Location
    Salzburg, AT
    Posts
    1,117

    Default Re: Default value ACL when no power supplied

    The red (no communication to the process) or blue (no communication to the zenon network server acquiring the process data) squares are never normal. The red or blue squares, so indication - on the variable status bits - that the variable values are not available, are forcing the ALC to behave different and to use another colors, as configured for the healthy communication. 

Similar Threads

  1. Power Curve
    By Praveen Kumar Karthikeyan in forum zenon Energy Edition
    Replies: 1
    Last Post: 31st July 2017, 12:15
  2. Power management system
    By arashsamavati in forum zenon Energy Edition
    Replies: 1
    Last Post: 22nd January 2016, 09:26
  3. Default user
    By rgv0021 in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 3
    Last Post: 23rd April 2015, 09:42
  4. Communication and CPU - Power Problems
    By marcel.widmer in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 3
    Last Post: 19th September 2014, 10:49
  5. Prot. Relay-Power supply failure monitoring
    By janlyndon in forum Engineering Studio & Service Engine (former zenon Editor & Runtime)
    Replies: 10
    Last Post: 18th May 2010, 22:57

Tags for this Thread

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •