View Full Version : VSTA Startproblem

1st March 2010, 15:01
I have recently upgraded 6.22 to 6.50 and cant seem to open the VSTA editor. Whenever i try there is no error message it just doesnt open. i have applied the correct setting (manually) to the zenon6.ini file to no avail. I did install 6.50 straight over the top of 6.22. does anyone know what could be causing the isuues?

1st March 2010, 23:13
which VSTA editor did you try to open?

With VSTA, you can open the VSTA IDE for the editor (workspace), through the file menu, or through the key combination "alt+F10".

You can open the VSTA IDE for the runtime (project), by right clicking in the "scripting" section of the project tree, and choose to start the VSTA IDE.

Did you check if you can open the VBA editor at all?

2nd March 2010, 10:03
I tried to open the editor VSTA from the programming interface tree node. There is no scripting node in my release of 6.50. There is the scripts node under the functions but there is no VSTA option when this is right clicked so i assume this is not what you mean

2nd March 2010, 10:33
Take a look into the zenon6.ini which is located in "C:\ProgramData\COPA-DATA\System"
-> simply enter %cd_system% into the address bar of the windows explorer.

In order to work with VSTA it is necessary to activate both (VBA and VSTA):



Take also a look into the help documentation where many useful information about VSTA is available:
Manual -> Programming interfaces -> VSTA -> Basics -> Setting up the VSTA environment


2nd March 2010, 12:07
Hi, alerady checked all those settings. Everything was correct (except CSHARP which was zero. I have also changed and checked this too.). I'm going to uninstall zenOn and start with a fresh install. cheers anyway

2nd March 2010, 23:31
Did you check, if you can start the VBA editor?

If you check the "info about" splashscreen (menu "help" -> "about") in the editor, is "VBA interface" included in the list?

8th March 2010, 14:58
VBA editor works fine. menu enteries are present as expected

9th March 2010, 00:18
I tried to open the editor VSTA from the programming interface tree node. There is no scripting node in my release of 6.50. There is the scripts node under the functions but there is no VSTA option when this is right clicked so i assume this is not what you mean

sorry, yes the tree node has been renamed to "programming interfaces" in 6.50. :o
Does it work when you open the VSTA editor through the file menu? When you open through the file menu, you open the VSTA editor, for the zenon editor. When you open through the programming interfaces node, you open the VSTA editor for the zenon runtime.

If you keep having issues, it might be an idea to contact your local support.

9th March 2010, 07:07
I did an installation of 6.22 SP1, on a clean Windows XP SP3 machine, and installed 6.50 SP0 build 1 on top.

After making the zenon6.ini entries, VSTA could be started without any issues, in 6.50.

In the 6.22 editor, the VSTA entries are also available (due to the ini entries), however as VSTA was only installed with 6.50, nothing happens when you try and start VSTA in the 6.22 editor.

Maybe you have not started the 6.50 editor, but try and attempt to start VSTA in the zenon 6.22 editor?

9th March 2010, 14:53
No i am in 6.50, the issue is appearing to be caused by having a full blown visual studio installation on the machine. I had VSTA working fine in work (but not at home) just installed Visual C# 2010 and VSTA stopped working in ZenOn. I have thoroughly read all the help files / forum posts / google enteries even all the stuff on ActiveX and WPF in the help files just in case there was some erroneously placed information. All i can say at this stage is anyone who intends to use VSTA SHOULD NOT INSTALL visual studio. I am in the process of raising this with COPA-DATA and will post the outcome as and when it is made available to me.

10th March 2010, 01:42
steve, thanks for your research and the information here. This may help other users affected by this issue as well.

I'm currently downloading the beta2 of visual studio 2010 express edition, and will try and install on a test system, to see if VSTA will continue to work.

Which version of visual C# 2010 / visual studio 2010 did you install?

It may also be that .NET 4.0, which comes with visual studio 2010, somehow interferes with VSTA.

10th March 2010, 10:40
I was able to reproduce this issue in a testenvironment. As soon as .NET 4.0 with Visual Studio 2010 is installed, the VSTA IDE in zenon will no longer open.

We've found out that the reason for this is actually a bug in the .NET 4.0 Framework, delivered with Visual Studio 2010 beta 2.

It appears that this issue is known to Microsoft experts and recognized as a bug.
Visual Studio 2010 at this point is still not officially released.

We assume, that this issue will be resolved before the official release of Visual Studio 2010, and will continue to monitor this. As soon as a newer version of Visual Studio is available, we will test again.

One workaround is to uninstall the beta or release candidate of Visual Studio 2010, including .NET 4.0.

Another workaround I would recommend, is to rename the folder "C:\WINDOWS\Microsoft.NET\Framework\v4.0.21006". After the folder is renamed and zenon is restarted, the VSTA IDE should open again. However I cannot tell how this will influence the Visual Studio 2010 installation.

another possible workaround will influence the usage of different zenon versions and VSTA (including any future versions of zenon) I will therefore not advertise the workaround here.

11th March 2010, 03:16
good news!

I have downloaded the latest release candidate (RC) of Microsoft Visual Studio 2010 pro, which actually contains a newer (v4.0.30128) version of the .NET 4 framework.

It appears this issue has been addressed by Microsoft in the Release Candidate.

When the release candidate of Visual Studio 2010 is installed on a PC where zenon 6.50 is installed, it is still possible to open the VSTA IDE in zenon.