PDA

View Full Version : Web Client - Visible Scrollbar on Internet Explorer in full screen mode



steven.costantini
15th February 2017, 08:50
Hi,
I'm using a PC (W10) as Web Client.
In full screen mode, there are scroolbars on the right and on the bottom of the screen.
I want to remove them.

STEP1- I opend Zenon6.ini and I configured ScreenProfile="Standard_1_m" where Standard_1_m is screen profile (1919x1079) defined in Zenon Project but situation remains the same. It seems even if I change resolution in screen profile, Runtime in web client doesn't respond to the changes.

STEP 2- I also modified ZOOM = 1 parameter in glob_var.js in wwwroot - zenon folder ( I don't remember if this is the correct path but I'm sure I changed Zoom parameter) to adapt Runtime to the screen but nothing has changed.

Someone could help me? I would to open Runtime in full screen mode without any scrollbars in the screen.

Thanks.

Steven Costantini.

georgk
15th February 2017, 09:22
Hi Steven,

Unserstanding how screen resolution and screen plofiles work with WebClients can be difficult:
- The Screen Profile (set Monitor Resolution) is not considered in the WebClient.
-> Thats what the ZOOM setting is for.
-> But his setting usually does not get you the desired result.
- On the WebClient the size of the ActiveX Element in the browser is the "screen-resolution" for the project.

A consistent way to get rid of the scrollbar is to change the zoom option in which the WebClient page is opened:
- this is configured in the initcode.js: "C:\inetpub\wwwroot\zenon\config\initcode.js"
- The bottom part descriibes the settings for opening with IE.
-> Setting it to 110% usually achieves the desired result:
document.write (' width=110%');
document.write (' height=110%');
Just refresh the WebClient to see the difference.

Hope this helps.

BR,
Georg