View Full Version : Problem with remote connection to Analyzer SQL Server

2nd July 2014, 14:26
Hello colleagues
I installed Zenon Analyzer v2.1 (SQL Server and Manager) on server computer with Windows 7 Professional Rus x64 and ZAMS on another engineering computer with Windows 7 Professional Rus x32.
ZAMS on server(local) PC can connect to Analyzer SQL Server without any problem.

But ZAMS on engineering computer couldn’t connect to Analyzer SQL Server. When I started function “Refresh server list” ZAMS didn’t show Analyzer SQL Server in scanning list at all. Although another SQL servers from server were displayed. If I specified database server manual when got error, screenshot is in attacmets.

Both computers are in common domain and have same users with authorization rights on the license server and Analyzer Manager. A network connection was established and tcp port is opened. The remote connection to Analyzer SQL server was allowed. All SQL server services were started.

Why ZAMS from engineering PC can’t find Analyzer SQL Server? How to find a reason?
Is this a limit of my demo license?

best regards

4th July 2014, 07:54
It is definatly not a restriction of the demo-license. You have all Options and it is just time limited.

What happens if you click on <Specify database Server> in the Login Dialog and you enter the SQL-instance manually? (Syntax: GERMANOV-NOTE\ZA2)
Then it directly tries to Access the SQL-Server. If this is successful, you just Need to select the database you want to be connected to from the list and confirm the Login Dialog.

7th July 2014, 09:12
Hello Thomas

When I click on <Specify database Server> in the Login Dialog and you enter the SQL-instance manually then I get error, you can see this error on screen shot in my previous message.

I also tried to connect to this SQL server from remote (engineering) PC using software built into windows. And got error - "SQL server not exist or access denied". But I already made full access for domain user, you can see screenshots in attachments.

A possibility to select necessary SQL server from list is better then waiting for 5 minutes for "Refresh server list" or to enter server name manually.

bet regars

7th July 2014, 12:19
For searching SQL-instances basic Windows functionality is used.. For any reasons the other PC cannot be seen. Can you ping the Analyzer Server from the Client-Computer? Can you connect from the Client Computer with the SQL Server Management Studio to the SQL-Instance? Did you try to disable the User Account Control?

Pease check this.

7th July 2014, 15:30
Hello Thomas

Ping to server by IP work good. But ping by name don't work and show incorrect IP address.
Tomorrow I will ask our admin about it.

7th July 2014, 15:55
Hello Altera,

ZAMS can also work with the IP-Address instead of the computer name. Unless you have solved the Problem with the Name Resolution you can use the IP.

8th July 2014, 08:12
Hello Thomas

Now ping to Analyzer server PC by name is OK.
But SQL Server Management Studio on client PC still can't connect to the SQL-Instance also.
May be google will help me but now I don't understand a reason.

8th July 2014, 12:57
Hello altera,

If also the SQL Server Management Studio cannot connect it must be a Basic Problem. I suppose you used the same user to Login as on the Analyzer Server. For me it seems to be a Firewall Problem on the Server or on the Client PC.

8th July 2014, 14:20
Hello Thomas
I could connect to Analyzer SQL server from client PC using SQL Server Management Studio with IP and port settings in connection string -,53317 \ZA2.
I tried this connection string in ZAMS and got message about license error, you can see screenshot in attachment.
But my demo license allow 1 client connection. Where can be a problem now?

best regards

8th July 2014, 15:07
Assigning an explicit port cannot work, as ZAMS Needs several Connections:
- SQL-Server Management Objects
- Reporting Services Web Service (usually Port 80)
- License Service (Port 50779)

Please also check, if the license Service on the Analyzer Server (zrsLicSrv) is running.