PDA

View Full Version : Web Client



gyu
1st March 2014, 19:34
Hi, All

Regarding a Web Server,

using a zenon 7.10 sp0 , web server standard.

when web client is started on other site , it has a error. (static ip : 88.201.53.179)

but, web client is work on web-server pc.

so, i attached some pic about setting on web server , runtime server and firewall.

plz tell me any info.

i can not leave this site -.-

* you can connect it with URL (88.201.53.179\zenon\index.htm)

* diagnosis viewer :
NetSrv WINSOCK ERROR--GetHostByName Failed Server:STP-OP1 Port:1102 GetHostByName error #11004

*********************************
attached file list
1. configuration
2. web-server PC gloval... , hosts etc
3. Runtime server PC hosts
4. Firewall set

louis.paglaiccetti
2nd March 2014, 17:08
Hello gyu,

Looking at your description and powerpoint, it appears as if your configuration on the zenon side is correct. Or at least, I do not see any obvious errors. This error message leads me to believe there is still a network related issue concerning name resolution.

Perhaps as a test, you can verify that you can successfully ping in the following situations:

- From the Web Client can you PING the Web Server via HOSTNAME?
- From the Web Server, can you PING the runtime server via HOSTNAME?

Can you successfully launch another web client from the INTERNAL network? If so, it may be worth investigating the Cisco firewall configuration. Additionally, if the web client successfully starts on web server machine, then I think that significantly narrows your problem down to network related issues (firewall, DNS, etc.).

Here are some additional topics that may be worth checking:


Is the name resolution in the network working correctly?
From the remote web Client computer can you ping the Server by hostname?
From a remote web Client computer can you ping the Server by IP address?
(a ping by must always return the identical name (Case sensitive!) on all PCs, use the option ping -4 to force IPv4)

Try to delete the %TEMP% directory on the web Client computer.

Try to add the URL of the zenon web Server to the “Trusted Sites” of Internet Explorer.

In Internet Explorer 10, try to turn on “Compatibility Mode” in the Tools menu.

Disable/uncheck memory protection in the browser (Tools -> Internet Options -> Advanced -> Enable memory protection to help mitigate online attacks).


If you still are unable to find the error, it would be highly suggested to contact your local Copa-Data support representative at that point.

gyu
4th March 2014, 07:18
Regarding a Enable DEP,

Should i uncheck a Enable DEP on the web server PC ??

herberto
4th March 2014, 08:27
DEP needs to be deactivated on the PC where the WebClient is running when using the browser Internet Explorer (and only if VBA is used in the project)
-> see http://www.copadata.com/forums/showthread.php?t=2327

regards,
herbert