PDA

View Full Version : Probleme Installation Webclient



garfield.79
8th December 2013, 11:49
Hallo an Alle :)

Habe ein kleines Problem bei der Installation bzw. beim starten des Webclients.

Habe über VPN Zugriff auf ein Netzwerk.
Kann dann über die Serveradresse auch die Default Webpage ansprechen.
Installation des Webclients haut auch noch hin.

Es handelt sich um: version710SP0

Aber wenn ich dann den Webclient starten will, kommt folgende Fehlermeldung:
(siehe Anhang)

Kann mir da bitte wer weiterhelfen.

Danke im Voraus und einen schönen Sonntag noch.

Lg

R.Zerer
8th December 2013, 13:43
Hallo,

die Meldung kommt nach meiner Erfahrung vom Browsercheck-Skript (JavaScript) und erfolgt, wenn der Webbrowser (offiziell) nicht unterstützt wird.

MfG
Robert

garfield.79
8th December 2013, 15:49
Ok, danke für den Hinweis.
Aber soll ich machen, wenn nur IE10 oder IE11 zur Verfügung steht?

Lg

R.Zerer
8th December 2013, 22:08
Hallo,

die Browsercheck-Datei kann man selbst bearbeiten, so dass auch andere Webbrowserversionen den WC starten - auf eigene Verantwortung.
Wir nutzen den WC mit IE10 und IE11 und haben keine Probleme damit.

Gruß
Robert

compu2000
9th December 2013, 09:04
Hallo,

aktivieren der Browserkompatibilität für diese Seite könnte auch helfen.

josefm
9th December 2013, 09:12
Hi,

also ich hab mir im Internet herausgesucht wie man am besten nach dem useragent vom IE11 sucht und mir folgendes zusammengestellt (ACHTUNG! Ist noch stark verbesserungswürdig, war jetzt nur um zu überprüfen ob es funktioniert ;)):

function browsercheck(){
var ua = navigator.userAgent;
var fWin32 = (ua.lastIndexOf('Win') != -1) && (ua.lastIndexOf('Windows 3.1') == -1) && (ua.lastIndexOf('Win16') == -1);
var fMSIE34567 = (ua.lastIndexOf('MSIE 3.0') != -1) || (ua.lastIndexOf('MSIE 4.0') != -1) || (ua.lastIndexOf('MSIE 5.0') != -1) || (ua.lastIndexOf('MSIE 5.5') != -1) || (ua.lastIndexOf('MSIE 6.0') != -1) || (ua.lastIndexOf('MSIE 7.0') != -1) || (ua.lastIndexOf('MSIE 8') != -1) || (ua.lastIndexOf('MSIE 9') != -1) || (ua.lastIndexOf('MSIE 10') != -1);
var fNS3456 = ((ua.lastIndexOf('Mozilla/6') != -1) || (ua.lastIndexOf('Mozilla/5') != -1) || (ua.lastIndexOf('Mozilla/4') != -1) || (ua.lastIndexOf('Mozilla/3') != -1)) && (ua.lastIndexOf('MSIE') == -1);
var fActiveX = fWin32 && fMSIE34567;
var fPlugIn = fWin32 && fNS3456;
var fDownlevel = !fActiveX && !fPlugIn;
// Process Mozilla Browser (Firefox, Netscape,...)
if (fPlugIn) {
// We have a Mozilla Browser here
if(getInternetExplorerVersion() == 11)
{
return "IEXPLORER";
}
else if(getInternetExplorerVersion() == -1)
{
return "NPAPI";
}
}
// Process Microsoft Internet Explorer (IE)
if (fActiveX)
{
// We have an Internet Explorer here
return "IEXPLORER";
}
// Process other browser and OS
if (fDownlevel)
{
// This browser was not recognized or is unsupported
return "UNSUPPORTED_BROWSER";
}
}

function getInternetExplorerVersion()
{
var rv = -1;
if (navigator.appName == 'Microsoft Internet Explorer')
{
var ua = navigator.userAgent;
var re = new RegExp("MSIE ([0-9]{1,}[\.0-9]{0,})");
if (re.exec(ua) != null)
rv = parseFloat( RegExp.$1 );
}
else if (navigator.appName == 'Netscape')
{
var ua = navigator.userAgent;
var re = new RegExp("Trident/.*rv:([0-9]{1,}[\.0-9]{0,})");
if (re.exec(ua) != null)
rv = parseFloat( RegExp.$1 );
}
return rv;
}

LG

garfield.79
11th December 2013, 14:38
@Josefm

Danke für die Info.
Habs grad ausprobiert, aber bekomme immer noch die gleiche Meldung retour. :(

Lg