PDA

View Full Version : Bericht kann nicht auf Reportserver hochgeladen werden



ptkdennis
29th November 2013, 10:38
Hallo!

Ich hab ein Problem mit dem hochladen von Berichten über die Weboberfläche.
Wenn ich meinen Bericht hochladen möchter erscheint die Fehlermeldung:
Maximale Anforderungslänge überschritten.

Anbei ein Screenshot.
Mein Bericht hat eine Größe von 5,5MB.

In diversen Foren wird geraten einen Parameter (maxrequestlength) in der Datei "web.config" zu ändern.
Dies habe ich in folgenden Pfad gemacht:
C:\Program Files\Microsoft SQL Server\MSRS11.ZA2\Reporting Services\ReportServer
Es brachte aber keine Besserung.

Hat jemand von euch einen Tipp, wie ich das Problem lösen kann?

MfG
Dennis

thomas.l
29th November 2013, 11:21
Generell empfiehlt es sich, nach einer Änderung der Web-Config den Report-Server-Dienst neu zu starten. Ansonsten hilft vielleicht das hier:

This problem occurs because the default value for the maxRequestLength parameter in the section of the Machine.config or Web.Config file is 4096 (4 megabytes). As a result, files that are larger than this value are not uploaded by default.

To resolve this problem, use one of the following methods:
In the Machine.config file, change the maxRequestLength attribute of the <httpRuntime> configuration section to a larger value. This change affects the whole computer.
In the Web.config file, override the value of maxRequestLength for the application. For example, the following entry in Web.config allows files that are less than or equal to 1 GB to be uploaded:
<httpRuntime maxRequestLength="1048576" />

Max value for maxRequestLength attribute is "1048576" (1 GB) for .NET Framework 1.0 or 1.1 and "2097151" (2 GB) for .NET Framework 2.0.

ptkdennis
3rd December 2013, 10:39
Hallo,

ich habe den Parameter in der "web.config" in den SQL-RS Verzeichnis angepasst und den Dienst neu gestartet, aber es funktioniert weiterhin nicht.

Wo genau kann ich die "machine.config" finden? Wenn ich die Datei suche erhalte ich sehr viele Ergebnisse.
Habe ich den Parameter in der richtigen "web.config" geändert? Wie bei der "machine.config" erhalte ich sehr viele Suchergebnisse.

Anbei 2 Screenshots.

MfG
Dennis

thomas.l
3rd December 2013, 13:11
Hier müßtest Du das korrekte machine.config finden.

c:\Windows\Microsoft.NET\Framework64\v2.0.50727\CO NFIG\

ptkdennis
17th February 2014, 10:58
Hallo,

ich konnte das Problem endlich lösen.
Zusätzlich zu der "web.config" im Ordner "C:\Program Files\Microsoft SQL Server\MSRS11.ZA2\Reporting Services\ReportServer"
musste man die "web.config" im Ordner "C:\Program Files\Microsoft SQL Server\MSRS11.ZA2\Reporting Services\ReportManager"
anpassen.

Da die Sektion "httpruntime"komplett gefehlt hat musste ich diese ebenfalls ergänzen.
Anbei meine Datei als Beispiel.

MfG
Dennis